aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-08 12:37:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-08 12:37:39 +0000
commitd07f0dcda12a06a8c40606610ff606fab54bd123 (patch)
treec3effa30424c6b4638df5ff1804b229ec12367dd /target/linux/omap/image
parente3b2c6418f6bad433429969526590831c0cb97e4 (diff)
downloadupstream-d07f0dcda12a06a8c40606610ff606fab54bd123.tar.gz
upstream-d07f0dcda12a06a8c40606610ff606fab54bd123.tar.bz2
upstream-d07f0dcda12a06a8c40606610ff606fab54bd123.zip
[omap]: rename the omap4 target to omap
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38691 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap/image')
-rw-r--r--target/linux/omap/image/Makefile32
-rw-r--r--target/linux/omap/image/boot.script3
2 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/omap/image/Makefile b/target/linux/omap/image/Makefile
new file mode 100644
index 0000000000..e118122bd4
--- /dev/null
+++ b/target/linux/omap/image/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'Boot Image' -d boot.script $(BIN_DIR)/boot.scr
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/omap/image/boot.script b/target/linux/omap/image/boot.script
new file mode 100644
index 0000000000..d884a70195
--- /dev/null
+++ b/target/linux/omap/image/boot.script
@@ -0,0 +1,3 @@
+fatload mmc 0:1 0x80000000 openwrt-omap-uImage
+setenv bootargs vram=32M fixrtc mem=1G@0x80000000 root=/dev/mmcblk0p2 rootfstype=ext4 console=ttyO2,115200n8 rootwait
+bootm 0x80000000