aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap/image/gen_omap_sdcard_img.sh
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-04-15 19:00:10 +0200
committerAlexander Couzens <lynxis@fe80.eu>2017-04-24 18:03:31 +0200
commit9b8e274e1b10a0d7a3066b5b1a62e24f7b313d9b (patch)
tree3a0f2014fdb43966d3285c3f31dfa4af3deed2c5 /target/linux/omap/image/gen_omap_sdcard_img.sh
parent23fc55e7235c719856ea4ba23a3dabb804d2fed9 (diff)
downloadupstream-9b8e274e1b10a0d7a3066b5b1a62e24f7b313d9b.tar.gz
upstream-9b8e274e1b10a0d7a3066b5b1a62e24f7b313d9b.tar.bz2
upstream-9b8e274e1b10a0d7a3066b5b1a62e24f7b313d9b.zip
omap: rework image generation and profiles
Migrate to new image generation and introduce sdcard generation (based on sunxi). Profile now generated via image/Makefile instead of profiles/ directory. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'target/linux/omap/image/gen_omap_sdcard_img.sh')
-rwxr-xr-xtarget/linux/omap/image/gen_omap_sdcard_img.sh33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/omap/image/gen_omap_sdcard_img.sh b/target/linux/omap/image/gen_omap_sdcard_img.sh
new file mode 100755
index 0000000000..c2f2aaddf4
--- /dev/null
+++ b/target/linux/omap/image/gen_omap_sdcard_img.sh
@@ -0,0 +1,33 @@
+#!/usr/bin/env bash
+
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+set -x
+[ $# -eq 5 ] || {
+ echo "SYNTAX: $0 <file> <bootfs image> <rootfs image> <bootfs size> <rootfs size>"
+ exit 1
+}
+
+OUTPUT="$1"
+BOOTFS="$2"
+ROOTFS="$3"
+BOOTFSSIZE="$4"
+ROOTFSSIZE="$5"
+
+head=4
+sect=63
+
+set `ptgen -o $OUTPUT -h $head -s $sect -l 1024 -t c -p ${BOOTFSSIZE}M -t 83 -p ${ROOTFSSIZE}M`
+
+BOOTOFFSET="$(($1 / 512))"
+BOOTSIZE="$(($2 / 512))"
+ROOTFSOFFSET="$(($3 / 512))"
+ROOTFSSIZE="$(($4 / 512))"
+
+dd bs=512 if="$BOOTFS" of="$OUTPUT" seek="$BOOTOFFSET" conv=notrunc
+dd bs=512 if="$ROOTFS" of="$OUTPUT" seek="$ROOTFSOFFSET" conv=notrunc