aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-08 12:44:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-08 12:44:38 +0000
commitc7080dcbb1aa3e7c5f721e21a38b05060de0f955 (patch)
treec29f003e41b07596aa0b0dff976c1dd1def8e893 /target/linux/omap/image/Makefile
parentd07f0dcda12a06a8c40606610ff606fab54bd123 (diff)
downloadupstream-c7080dcbb1aa3e7c5f721e21a38b05060de0f955.tar.gz
upstream-c7080dcbb1aa3e7c5f721e21a38b05060de0f955.tar.bz2
upstream-c7080dcbb1aa3e7c5f721e21a38b05060de0f955.zip
[omap]: switch to 3.12, enable support for AM33xx/OMAP3
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38692 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap/image/Makefile')
-rw-r--r--target/linux/omap/image/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/target/linux/omap/image/Makefile b/target/linux/omap/image/Makefile
index e118122bd4..afd8398e2f 100644
--- a/target/linux/omap/image/Makefile
+++ b/target/linux/omap/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,11 @@ include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'Boot Image' -d boot.script $(BIN_DIR)/boot.scr
- cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+ cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+ -mkdir $(BIN_DIR)/dtbs
+ $(CP) $(LINUX_DIR)/arch/arm/boot/dts/am335x*.dtb $(BIN_DIR)/dtbs/
+ $(CP) $(LINUX_DIR)/arch/arm/boot/dts/omap3*.dtb $(BIN_DIR)/dtbs/
+ $(CP) $(LINUX_DIR)/arch/arm/boot/dts/omap4*.dtb $(BIN_DIR)/dtbs/
endef
define Image/Build