aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/olpc
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-05-14 10:20:53 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-05-14 10:20:53 +0000
commit476b993379210c4e3a760564fc0614f1cb63b521 (patch)
tree0589c0ee59913f1c0790d02030b654601bf7a6a5 /target/linux/olpc
parentf75c2b26445e4231c15b7735974f692facb0daa9 (diff)
downloadupstream-476b993379210c4e3a760564fc0614f1cb63b521.tar.gz
upstream-476b993379210c4e3a760564fc0614f1cb63b521.tar.bz2
upstream-476b993379210c4e3a760564fc0614f1cb63b521.zip
make kernels use /etc/preinit by default
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15840 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/olpc')
-rw-r--r--target/linux/olpc/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/olpc/image/Makefile b/target/linux/olpc/image/Makefile
index 4945022ba7..eb1bedd0a0 100644
--- a/target/linux/olpc/image/Makefile
+++ b/target/linux/olpc/image/Makefile
@@ -15,19 +15,19 @@ ROOTDELAY=5
ifeq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),y)
define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit rootdelay=$(ROOTDELAY)
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootdelay=$(ROOTDELAY)
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit rootdelay=$(ROOTDELAY)
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit rootdelay=$(ROOTDELAY)
+ block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
endef
define Image/cmdline/ext2
- root=$(ROOTPART) rootfstype=ext2 init=/etc/preinit
+ root=$(ROOTPART) rootfstype=ext2
endef
define Image/Build/bootscript