aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/olpc/Makefile
diff options
context:
space:
mode:
authorJens Muecke <jens@nons.de>2007-10-28 21:20:48 +0000
committerJens Muecke <jens@nons.de>2007-10-28 21:20:48 +0000
commit524a044e932fad3550800f69d241026b89975ac9 (patch)
tree0acbcbe63c97fb363177aaecfc63b0965b336ddf /target/linux/olpc/Makefile
parentbff0d1a414b383db5ac6f032bd7884016f652187 (diff)
downloadupstream-524a044e932fad3550800f69d241026b89975ac9.tar.gz
upstream-524a044e932fad3550800f69d241026b89975ac9.tar.bz2
upstream-524a044e932fad3550800f69d241026b89975ac9.zip
Initial OLPC target
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9457 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/olpc/Makefile')
-rw-r--r--target/linux/olpc/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/olpc/Makefile b/target/linux/olpc/Makefile
new file mode 100644
index 0000000000..4ab3375373
--- /dev/null
+++ b/target/linux/olpc/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH=i386
+BOARD:=olpc
+BOARDNAME:=olpc
+FEATURES:=squashfs ext2
+
+LINUX_VERSION:=2.6.23
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+
+$(eval $(call Target,generic))
+$(eval $(call BuildTarget))
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
+ Please install mkisofs. \
+))