aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeontx
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2023-02-17 17:06:41 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-26 22:22:48 +0100
commitfb2480df36fa4f8faed9732ed06ac2093a060c28 (patch)
tree3e2df8ed068e10923ddea2c97c2346f43213b7b1 /target/linux/octeontx
parent43c7132bf8e7dc0756b527f985a1ac6056007f62 (diff)
downloadupstream-fb2480df36fa4f8faed9732ed06ac2093a060c28.tar.gz
upstream-fb2480df36fa4f8faed9732ed06ac2093a060c28.tar.bz2
upstream-fb2480df36fa4f8faed9732ed06ac2093a060c28.zip
octeontx: add default packages for on-board devices
The Gateworks Newport boards supported by the octeontx target have the following on-board devices: - Gateworks System Controller - GPIO buttons - GPIO leds - GPS PPS - Accelerometer - MCP251X CAN controller Add kernel drivers for these devices in DEFAULT_PACKAGES Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Diffstat (limited to 'target/linux/octeontx')
-rw-r--r--target/linux/octeontx/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/octeontx/Makefile b/target/linux/octeontx/Makefile
index 5260291d05..25096c90ba 100644
--- a/target/linux/octeontx/Makefile
+++ b/target/linux/octeontx/Makefile
@@ -20,4 +20,8 @@ include $(INCLUDE_DIR)/target.mk
KERNELNAME:=Image
+DEFAULT_PACKAGES += kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
+ kmod-gpio-button-hotplug kmod-input-evdev kmod-rtc-ds1672 \
+ kmod-can kmod-can-mcp251x
+
$(eval $(call BuildTarget))