aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeontx
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2023-02-21 15:08:29 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-26 22:22:48 +0100
commit026004d5301a273005390f0a0cd26539fbee09f1 (patch)
tree46caf5cfe0a4c0c04fe3b583a13b631dd847720b /target/linux/octeontx
parentfb2480df36fa4f8faed9732ed06ac2093a060c28 (diff)
downloadupstream-026004d5301a273005390f0a0cd26539fbee09f1.tar.gz
upstream-026004d5301a273005390f0a0cd26539fbee09f1.tar.bz2
upstream-026004d5301a273005390f0a0cd26539fbee09f1.zip
octeontx: add f2fs and ext4 support
Add both ext4 and f2fs support for overlayfs. The fstools mount_root application will choose f2fs if the overlay volume space available exceeds 100MB, otherwise ext4 is used. Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Diffstat (limited to 'target/linux/octeontx')
-rw-r--r--target/linux/octeontx/Makefile3
-rw-r--r--target/linux/octeontx/config-5.152
2 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/octeontx/Makefile b/target/linux/octeontx/Makefile
index 25096c90ba..57250a5e01 100644
--- a/target/linux/octeontx/Makefile
+++ b/target/linux/octeontx/Makefile
@@ -20,7 +20,8 @@ include $(INCLUDE_DIR)/target.mk
KERNELNAME:=Image
-DEFAULT_PACKAGES += kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
+DEFAULT_PACKAGES += uboot-envtools mkf2fs e2fsprogs blkid \
+ kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
kmod-gpio-button-hotplug kmod-input-evdev kmod-rtc-ds1672 \
kmod-can kmod-can-mcp251x
diff --git a/target/linux/octeontx/config-5.15 b/target/linux/octeontx/config-5.15
index 36402b70eb..40cab28f60 100644
--- a/target/linux/octeontx/config-5.15
+++ b/target/linux/octeontx/config-5.15
@@ -145,6 +145,8 @@ CONFIG_EDAC_SUPPORT=y
CONFIG_EDAC_THUNDERX=y
# CONFIG_EDAC_XGENE is not set
CONFIG_EEPROM_AT24=y
+CONFIG_EXT4_FS=y
+CONFIG_F2FS_FS=y
CONFIG_FAT_FS=y
CONFIG_FIXED_PHY=y
CONFIG_FIX_EARLYCON_MEM=y