aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeontx/image
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2018-01-23 15:15:44 -0800
committerJohn Crispin <john@phrozen.org>2018-02-13 10:01:52 +0100
commitfc03b3aa1610feed89b04aa504a3468c904a1aae (patch)
treeeea5c53927f464f9a11489b5daf15a4a0ca7ad4a /target/linux/octeontx/image
parent123dbb77aa24842ed00e566b3e01536535407d66 (diff)
downloadupstream-fc03b3aa1610feed89b04aa504a3468c904a1aae.tar.gz
upstream-fc03b3aa1610feed89b04aa504a3468c904a1aae.tar.bz2
upstream-fc03b3aa1610feed89b04aa504a3468c904a1aae.zip
octeontx: add support for OCTEON TX target
The Cavium OCTEON TX is an ARM 64-bit SoC leveraging CPU cores and periperhals from the Cavium ThunderX SoC. This initial support provides a 4.14 kernel and kernel+initramfs that is bootable on the Gateworks Newport GW630x as well as the Cavium sff8104 reference board. Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Diffstat (limited to 'target/linux/octeontx/image')
-rw-r--r--target/linux/octeontx/image/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/octeontx/image/Makefile b/target/linux/octeontx/image/Makefile
new file mode 100644
index 0000000000..203f0ea5c6
--- /dev/null
+++ b/target/linux/octeontx/image/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2018 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Build/Initramfs
+ $(CP) $(KERNEL_BUILD_DIR)/vmlinux $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
+ $(CP) $(KERNEL_BUILD_DIR)/vmlinux-initramfs $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+ cp $(KDIR)/vmlinux $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
+endef
+
+$(eval $(call BuildImage))