aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeontx/Makefile
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2018-01-23 15:15:44 -0800
committerJohn Crispin <john@phrozen.org>2018-02-13 10:01:52 +0100
commitfc03b3aa1610feed89b04aa504a3468c904a1aae (patch)
treeeea5c53927f464f9a11489b5daf15a4a0ca7ad4a /target/linux/octeontx/Makefile
parent123dbb77aa24842ed00e566b3e01536535407d66 (diff)
downloadupstream-fc03b3aa1610feed89b04aa504a3468c904a1aae.tar.gz
upstream-fc03b3aa1610feed89b04aa504a3468c904a1aae.tar.bz2
upstream-fc03b3aa1610feed89b04aa504a3468c904a1aae.zip
octeontx: add support for OCTEON TX target
The Cavium OCTEON TX is an ARM 64-bit SoC leveraging CPU cores and periperhals from the Cavium ThunderX SoC. This initial support provides a 4.14 kernel and kernel+initramfs that is bootable on the Gateworks Newport GW630x as well as the Cavium sff8104 reference board. Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Diffstat (limited to 'target/linux/octeontx/Makefile')
-rw-r--r--target/linux/octeontx/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/octeontx/Makefile b/target/linux/octeontx/Makefile
new file mode 100644
index 0000000000..bbe8149b0b
--- /dev/null
+++ b/target/linux/octeontx/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2018 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=aarch64
+BOARD:=octeontx
+BOARDNAME:=Octeon-TX
+FEATURES:=targz pcie gpio rtc usb
+CFLAGS:=-Os -pipe -fno-caller-saves
+
+MAINTAINER:=Tim Harvey <tharvey@gateworks.com>
+
+KERNEL_PATCHVER:=4.14
+
+define Target/Description
+ Build images for Octeon-TX CN80XX/CN81XX based boards
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=Image
+
+$(eval $(call BuildTarget))