aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2022-06-07 13:26:43 +0200
committerPaul Spooren <mail@aparcar.org>2022-06-09 17:14:28 +0200
commit2a07270180ed0e295d854d6e9e59c78c40549efc (patch)
tree02a3add206a23f26ab7ed087f28c131bd72c856b /target/linux/octeon
parentab1f3a87063b94f485bd582f32a066b80007bac9 (diff)
downloadupstream-2a07270180ed0e295d854d6e9e59c78c40549efc.tar.gz
upstream-2a07270180ed0e295d854d6e9e59c78c40549efc.tar.bz2
upstream-2a07270180ed0e295d854d6e9e59c78c40549efc.zip
octeon: add SUPPORTED_DEVICES to er/erlite
Using the BOARD_NAME variable results for both er and erlite devices to identify themselfs as `er` and `erlite` (via `ubus call system board`). This is problematic when devices search for firmware upgrades since the OpenWrt profile is actually called `ubnt_edgerouter` and `ubnt_edgerouter-lite`. By adding the `SUPPORTED_DEVICE` a mapping is created to point devices called `er` or `erlite` to the corresponding profile. FIXES: https://github.com/openwrt/asu/issues/348 Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index f77159e1f9..23adb884f8 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -48,6 +48,7 @@ define Device/ubnt_edgerouter
DEVICE_MODEL := EdgeRouter
BOARD_NAME := er
CMDLINE := $(ER_CMDLINE)
+ SUPPORTED_DEVICES += er
endef
TARGET_DEVICES += ubnt_edgerouter
@@ -79,6 +80,7 @@ define Device/ubnt_edgerouter-lite
DEVICE_MODEL := EdgeRouter Lite
BOARD_NAME := erlite
CMDLINE := $(ERLITE_CMDLINE)
+ SUPPORTED_DEVICES += erlite
endef
TARGET_DEVICES += ubnt_edgerouter-lite