aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-09-11 13:52:31 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-09-24 23:53:53 +0200
commita67f484e67b1d0930cb4b10b9e3787ecf7e71579 (patch)
tree4b03181f56288857579a7eeae89542f88fd8b012 /target/linux/octeon
parent99b6e3cb41826cb920ddf06ee4ad447d71effc12 (diff)
downloadupstream-a67f484e67b1d0930cb4b10b9e3787ecf7e71579.tar.gz
upstream-a67f484e67b1d0930cb4b10b9e3787ecf7e71579.tar.bz2
upstream-a67f484e67b1d0930cb4b10b9e3787ecf7e71579.zip
octeon: fix imagebuilder generation by introducing generic target
The generic imagebuilder does not have a generic in the name, although this is the default naming scheme. Use bcm53xx as template for this fix. Before the fix: openwrt-imagebuilder-octeon.Linux-x86_64.tar.xz After: openwrt-imagebuilder-octeon-generic.Linux-x86_64.tar.xz Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/generic/target.mk1
-rw-r--r--target/linux/octeon/profiles/000-Generic.mk9
2 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/octeon/generic/target.mk b/target/linux/octeon/generic/target.mk
new file mode 100644
index 0000000000..f5cb1fb19b
--- /dev/null
+++ b/target/linux/octeon/generic/target.mk
@@ -0,0 +1 @@
+BOARDNAME:=Generic
diff --git a/target/linux/octeon/profiles/000-Generic.mk b/target/linux/octeon/profiles/000-Generic.mk
index 6d5aa4e2bd..b7261cd355 100644
--- a/target/linux/octeon/profiles/000-Generic.mk
+++ b/target/linux/octeon/profiles/000-Generic.mk
@@ -2,13 +2,12 @@
#
# Copyright (C) 2013 OpenWrt.org
-define Profile/Default
- NAME:=Default Profile
- PRIORITY:=1
+define Profile/Generic
+ NAME:=Octeon SoC
endef
-define Profile/Default/Description
+define Profile/Generic/Description
Base packages for Octeon boards.
endef
-$(eval $(call Profile,Default))
+$(eval $(call Profile,Generic))