aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-06 20:05:39 +0000
committerJohn Crispin <john@openwrt.org>2014-10-06 20:05:39 +0000
commit90cbc9a04fce0bee57bd7b2983e6ae570edfb189 (patch)
treea991ae150c7605aedd560f5832902b781ce7afb0 /target/linux/octeon
parent3ff9c76e9e4acf0c47c9ea1f299194c32381b20f (diff)
downloadupstream-90cbc9a04fce0bee57bd7b2983e6ae570edfb189.tar.gz
upstream-90cbc9a04fce0bee57bd7b2983e6ae570edfb189.tar.bz2
upstream-90cbc9a04fce0bee57bd7b2983e6ae570edfb189.zip
octeon: prepare elf kernel image and md5sum for usb copying
Signed-off-by: Roman Yeryomin <roman@advem.lv> SVN-Revision: 42809
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 25a81496b2..f06dd6bcfe 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -12,6 +12,8 @@ define Image/BuildKernel
$(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma bs=65536 conv=sync
+ $(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/vmlinux.64
+ md5sum $(BIN_DIR)/vmlinux.64 | cut -d " " -f 1 | tee $(BIN_DIR)/vmlinux.64.md5
endef
define Image/Build/squashfs