aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-03 13:42:28 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-03 13:42:28 +0000
commit6b2a7b73ca8ba542fd2cbd21c615933b99e293ba (patch)
treebe1f22c1565b6e16079e8f09a60bc3899fc6b0a2 /target/linux/octeon
parent3d3d75a2489789df49a4985600f5cd5cb95dbaf8 (diff)
downloadupstream-6b2a7b73ca8ba542fd2cbd21c615933b99e293ba.tar.gz
upstream-6b2a7b73ca8ba542fd2cbd21c615933b99e293ba.tar.bz2
upstream-6b2a7b73ca8ba542fd2cbd21c615933b99e293ba.zip
upgrade to 2.6.30-rc8
SVN-Revision: 16307
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/Makefile2
-rw-r--r--target/linux/octeon/patches/001-handle_removal_h_constraint.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
index 3cf814866c..4f344a3827 100644
--- a/target/linux/octeon/Makefile
+++ b/target/linux/octeon/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Octeon
FEATURES:=squashfs jffs2 pci
CFLAGS:=-Os -pipe -funit-at-a-time
-LINUX_VERSION:=2.6.30-rc7
+LINUX_VERSION:=2.6.30-rc8
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/octeon/patches/001-handle_removal_h_constraint.patch b/target/linux/octeon/patches/001-handle_removal_h_constraint.patch
index b37b4a7577..48c41d74d5 100644
--- a/target/linux/octeon/patches/001-handle_removal_h_constraint.patch
+++ b/target/linux/octeon/patches/001-handle_removal_h_constraint.patch
@@ -12,8 +12,8 @@ Signed-off-by: David Daney <ddaney@caviumnetworks.com>
--- a/arch/mips/include/asm/compiler.h
+++ b/arch/mips/include/asm/compiler.h
-@@ -16,4 +16,11 @@
- #define GCC_REG_ACCUM "accum"
+@@ -26,4 +26,11 @@ typedef u64 uintx_t;
+ #endif
#endif
+#if __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 4)
@@ -26,7 +26,7 @@ Signed-off-by: David Daney <ddaney@caviumnetworks.com>
#endif /* _ASM_COMPILER_H */
--- a/arch/mips/include/asm/delay.h
+++ b/arch/mips/include/asm/delay.h
-@@ -83,10 +83,14 @@ static inline void __udelay(unsigned lon
+@@ -67,10 +67,14 @@ static inline unsigned long __usecs_to_l
: "r" (usecs), "r" (lpj)
: GCC_REG_ACCUM);
else if (sizeof(long) == 8 && !R4000_WAR)