aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/profiles
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-09-11 13:52:31 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-23 14:21:03 +0200
commite946d9aa9d90ceefbd4a0c9e22a39767dc494afb (patch)
tree6d3a6e7b7db5bb4a07ea78c5da180ee48dbc2e10 /target/linux/octeon/profiles
parent6cffcb2e9fce3036b70721c634278614d72885db (diff)
downloadupstream-e946d9aa9d90ceefbd4a0c9e22a39767dc494afb.tar.gz
upstream-e946d9aa9d90ceefbd4a0c9e22a39767dc494afb.tar.bz2
upstream-e946d9aa9d90ceefbd4a0c9e22a39767dc494afb.zip
octeon: fix imagebuilder generation by introducing generic target
The generic imagebuilder does not have a generic in the name, although this is the default naming scheme. Use bcm53xx as template for this fix. Before the fix: openwrt-imagebuilder-octeon.Linux-x86_64.tar.xz After: openwrt-imagebuilder-octeon-generic.Linux-x86_64.tar.xz Signed-off-by: Nick Hainke <vincent@systemli.org> (cherry picked from commit a67f484e67b1d0930cb4b10b9e3787ecf7e71579)
Diffstat (limited to 'target/linux/octeon/profiles')
-rw-r--r--target/linux/octeon/profiles/000-Generic.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/octeon/profiles/000-Generic.mk b/target/linux/octeon/profiles/000-Generic.mk
index 6d5aa4e2bd..b7261cd355 100644
--- a/target/linux/octeon/profiles/000-Generic.mk
+++ b/target/linux/octeon/profiles/000-Generic.mk
@@ -2,13 +2,12 @@
#
# Copyright (C) 2013 OpenWrt.org
-define Profile/Default
- NAME:=Default Profile
- PRIORITY:=1
+define Profile/Generic
+ NAME:=Octeon SoC
endef
-define Profile/Default/Description
+define Profile/Generic/Description
Base packages for Octeon boards.
endef
-$(eval $(call Profile,Default))
+$(eval $(call Profile,Generic))