aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/image/Makefile
diff options
context:
space:
mode:
authorDonald Hoskins <grommish@gmail.com>2020-07-22 05:26:33 -0400
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-16 02:15:06 +0200
commiteadb1a943744997a8685c6de97a25d60d258af85 (patch)
tree6ac95ad89060c1dbaac247ffb931f934e874309b /target/linux/octeon/image/Makefile
parent591767fc0152ffd02954e359e33f575271b9089e (diff)
downloadupstream-eadb1a943744997a8685c6de97a25d60d258af85.tar.gz
upstream-eadb1a943744997a8685c6de97a25d60d258af85.tar.bz2
upstream-eadb1a943744997a8685c6de97a25d60d258af85.zip
octeon: add support for Itus Shield Router
Itus Networks Shield - 1Ghz dual-core mips64 / Cavium Octeon 3 SoC, 1Gb RAM, 4Gb eMMC,3 GbE 10/100/1000 ports Information regarding device can be found: https://deviwiki.com/wiki/Itus_Networks_Shield_Pro Installing OpenWrt on Itus Networks Shield: 1) Boot Shield 2) On device: mount /dev/mmcblk1p1 /mnt 3) scp openwrt-octeon-itus,shield-router-initramfs-kernel.bin to /mnt/ItusrouterImage 3a) Optionally: scp openwrt-octeon-itus,shield-router-initramfs-kernel.bin to /mnt/ItusgatewayImage to allow you to have an emergency recovery boot in the GATEWAY slot - this slot will have no permament storage and is used for emergency recovery only when booted in the (G)ateway position 4) On device: umount /mnt 5) reboot Once booted, run the sysupgrade via cli or luCi on the openwrt-octeon-itus,shield-router-squashfs-sysupgrade.tar file the mode you are running. Once rebooted, the system installation is complete. Your storage partition for the mode is inialized and set. Signed-off-by: Donald Hoskins <grommish@gmail.com> [cut out sysupgrade-* changes, move a few lines, drop case CVMX_BOARD_TYPE_ITUS_SHIELD] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/octeon/image/Makefile')
-rw-r--r--target/linux/octeon/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index e083e823c2..1dbb60edbc 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -29,6 +29,15 @@ define Device/generic
endef
TARGET_DEVICES += generic
+ITUSROUTER_CMDLINE:=console=ttyS0,115200 root=/dev/mmcblk1p2 rootfstype=squashfs,ext4,f2fs rootwait
+define Device/itus_shield-router
+ DEVICE_VENDOR := Itus Networks
+ DEVICE_MODEL := Shield Router
+ CMDLINE := $(ITUSROUTER_CMDLINE)
+ IMAGE/sysupgrade.tar/squashfs += | append-metadata
+endef
+TARGET_DEVICES += itus_shield-router
+
ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
define Device/ubnt_edgerouter
DEVICE_VENDOR := Ubiquiti