aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-08-04 13:54:32 +0000
committerJohn Crispin <blogic@openwrt.org>2013-08-04 13:54:32 +0000
commitc90d6b25d5aaadf371db8452b82f1700853cd22a (patch)
tree65f59e68b2808f14d423f2229930be664ce7e846 /target/linux/octeon/image/Makefile
parent93f6b2a5419b21dd291f4eb0d6458e6432ea0e84 (diff)
downloadupstream-c90d6b25d5aaadf371db8452b82f1700853cd22a.tar.gz
upstream-c90d6b25d5aaadf371db8452b82f1700853cd22a.tar.bz2
upstream-c90d6b25d5aaadf371db8452b82f1700853cd22a.zip
octeon: add support for the octeon mips64 SoC
This is the SoC used be the ESR Lite made by ubnt.com Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37684 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/octeon/image/Makefile')
-rw-r--r--target/linux/octeon/image/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
new file mode 100644
index 0000000000..358bbe8aae
--- /dev/null
+++ b/target/linux/octeon/image/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
+ $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
+ dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma bs=65536 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))