aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-02 09:18:55 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-02 09:18:55 +0000
commitfb4eb1628390b715abcf050c1d8008b9dd1b2e23 (patch)
treebbe270ef7bf7f26a10514e0344a484f6bc9be14b /target/linux/octeon/Makefile
parentc5d88f6551c47e46be7d4f4bc1eb14978528311f (diff)
downloadupstream-fb4eb1628390b715abcf050c1d8008b9dd1b2e23.tar.gz
upstream-fb4eb1628390b715abcf050c1d8008b9dd1b2e23.tar.bz2
upstream-fb4eb1628390b715abcf050c1d8008b9dd1b2e23.zip
rename cavium-octeon to octeon
SVN-Revision: 16292
Diffstat (limited to 'target/linux/octeon/Makefile')
-rw-r--r--target/linux/octeon/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
new file mode 100644
index 0000000000..3cf814866c
--- /dev/null
+++ b/target/linux/octeon/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=octeon
+BOARDNAME:=Cavium Networks Octeon
+FEATURES:=squashfs jffs2 pci
+CFLAGS:=-Os -pipe -funit-at-a-time
+
+LINUX_VERSION:=2.6.30-rc7
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += hostapd-mini
+
+define Target/Description
+ Build firmware images for Cavium Networks Octeon-based boards.
+endef
+
+$(eval $(call BuildTarget))