aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/netlogic/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-10-24 00:16:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-10-24 00:16:23 +0000
commitc6285fd82f1b631b77ad94be613dc4575cd9ed28 (patch)
treee3f509c9f2a585646d3e52f81e4fd0961bbb32ce /target/linux/netlogic/Makefile
parent2c62ad1fda41da36baaf3524440aa631c5fb81c6 (diff)
downloadupstream-c6285fd82f1b631b77ad94be613dc4575cd9ed28.tar.gz
upstream-c6285fd82f1b631b77ad94be613dc4575cd9ed28.tar.bz2
upstream-c6285fd82f1b631b77ad94be613dc4575cd9ed28.zip
netlogic: add XLR/XLP support
Add support for Broadcom/Netlogic XLR/XLP support Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43037
Diffstat (limited to 'target/linux/netlogic/Makefile')
-rw-r--r--target/linux/netlogic/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/netlogic/Makefile b/target/linux/netlogic/Makefile
new file mode 100644
index 0000000000..e3aa572b74
--- /dev/null
+++ b/target/linux/netlogic/Makefile
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips64
+BOARD:=netlogic
+BOARDNAME:=Broadcom/Netlogic XLP/XLR
+FEATURES:=squashfs jffs2 ext4 pci usb
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=xlp xlr
+
+LINUX_VERSION:=3.14.16
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))