aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/profiles
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2013-10-14 21:22:40 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2013-10-14 21:22:40 +0000
commitc4bccca659fb4c5443731ac998c6e2a6a52b1674 (patch)
tree3db80590365c4782e1a36be6f4cd90044ccc1c98 /target/linux/mxs/profiles
parent4f2289e110c58aa93d62a664b66b022ad9bb9f49 (diff)
downloadupstream-c4bccca659fb4c5443731ac998c6e2a6a52b1674.tar.gz
upstream-c4bccca659fb4c5443731ac998c6e2a6a52b1674.tar.bz2
upstream-c4bccca659fb4c5443731ac998c6e2a6a52b1674.zip
mxs: add support for I2SE Duckbill devices
Signed-off-by: Michael Heimpold <mhei@heimpold.de> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38407 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mxs/profiles')
-rw-r--r--target/linux/mxs/profiles/02-duckbill.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mxs/profiles/02-duckbill.mk b/target/linux/mxs/profiles/02-duckbill.mk
new file mode 100644
index 0000000000..847460ac31
--- /dev/null
+++ b/target/linux/mxs/profiles/02-duckbill.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/duckbill
+ NAME:=I2SE Duckbill series
+ DEPENDS:=+@TARGET_ROOTFS_INCLUDE_KERNEL +@TARGET_ROOTFS_INCLUDE_DTB
+ PACKAGES+= \
+ -dnsmasq -firewall -ppp -ip6tables -iptables -6relayd -mtd uboot-envtools \
+ kmod-leds-gpio kmod-ledtrig-timer kmod-usb-mxs-phy -kmod-ipt-nathelper
+endef
+
+define Profile/duckbill/Description
+ I2SE's Duckbill devices
+endef
+
+$(eval $(call Profile,duckbill))