aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-07-29 10:25:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-07-29 10:25:40 +0000
commit155510ec8e938f5bea4a35a5e11d93b81ed6bd20 (patch)
treed74d016bc5e75029d5fd0aa187c01177408993d5 /target/linux/mxs/image/Makefile
parenta40fb63ca6c4dbe2868f2e11d1d9985f31de131c (diff)
downloadupstream-155510ec8e938f5bea4a35a5e11d93b81ed6bd20.tar.gz
upstream-155510ec8e938f5bea4a35a5e11d93b81ed6bd20.tar.bz2
upstream-155510ec8e938f5bea4a35a5e11d93b81ed6bd20.zip
BB: remove some targets that are broken or have the wrong kernel version
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@41876 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mxs/image/Makefile')
-rw-r--r--target/linux/mxs/image/Makefile69
1 files changed, 0 insertions, 69 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
deleted file mode 100644
index c29925f2d8..0000000000
--- a/target/linux/mxs/image/Makefile
+++ /dev/null
@@ -1,69 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-BOARDS:= \
- imx23-olinuxino \
- imx28-duckbill
-
-define Image/BuildKernel/olinuxino-bootlet
- cat $(LINUX_DIR)/arch/arm/boot/zImage $(DTS_DIR)/imx23-olinuxino.dtb > $(STAGING_DIR)/zImage_dtb
- (cd $(STAGING_DIR); \
- $(STAGING_DIR)/../host/bin/elftosb -z -c ./linux_prebuilt.db -o linux.sb; \
- dd if=/dev/zero of=sd_mmc_bootstream.raw bs=512 count=4; \
- dd if=linux.sb of=$(BIN_DIR)/openwrt-imx23-sbImage ibs=512 seek=4; \
- )
-endef
-
-define Image/BuildKernel/mxs-uboot
- mkimage -A arm -O linux -T kernel -C none \
- -a 0x40008000 -e 0x40008000 \
- -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/zImage $(KDIR)/uImage
- cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
-endef
-
-define Image/BuildKernel
-
- ifeq ($(CONFIG_PACKAGE_imx-bootlets),y)
- $(call Image/BuildKernel/olinuxino-bootlet)
- endif
-
- ifeq ($(CONFIG_PACKAGE_uboot-mxs-mx23_olinuxino),y)
- $(call Image/BuildKernel/mxs-uboot)
- endif
-
- $(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
- $(foreach board,$(BOARDS),
- $(CP) $(DTS_DIR)/$(board).dtb $(BIN_DIR)/
- )
-endef
-
-define Image/InstallKernel
-
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
- mkdir -p $(TARGET_DIR)/boot
- $(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(TARGET_DIR)/boot/
- endif
-
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
- mkdir -p $(TARGET_DIR)/boot
- $(foreach board,$(BOARDS),
- $(CP) $(DTS_DIR)/$(board).dtb $(TARGET_DIR)/boot/
- )
- endif
-
-endef
-
-define Image/Build
- $(call Image/Build/$(1))
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
-endef
-
-$(eval $(call BuildImage))