aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2022-03-21 11:47:27 +0100
committerPetr Štetiar <ynezz@true.cz>2022-03-21 14:00:34 +0100
commit80f21e53360d52d493c51a4a263d9b7607b7494e (patch)
tree127cc4c3e14c626b03e935407afec7c2a8e909c3 /target/linux/mvebu
parent17004245534731ab03c9a8683208e84d9c399979 (diff)
downloadupstream-80f21e53360d52d493c51a4a263d9b7607b7494e.tar.gz
upstream-80f21e53360d52d493c51a4a263d9b7607b7494e.tar.bz2
upstream-80f21e53360d52d493c51a4a263d9b7607b7494e.zip
mvebu: udpu: fix initramfs booting
uDPU provides a FIT based initramfs, but currently gets stuck after U-boot starts the kernel at "Starting kernel..". It is due to the load address being too low, so increase it in order to get the initramfs booting again. Signed-off-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/cortexa53.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/cortexa53.mk b/target/linux/mvebu/image/cortexa53.mk
index ca3a53f992..46f04fe7cc 100644
--- a/target/linux/mvebu/image/cortexa53.mk
+++ b/target/linux/mvebu/image/cortexa53.mk
@@ -82,7 +82,7 @@ define Device/methode_udpu
DEVICE_VENDOR := Methode
DEVICE_MODEL := micro-DPU (uDPU)
DEVICE_DTS := armada-3720-uDPU
- KERNEL_LOADADDR := 0x00080000
+ KERNEL_LOADADDR := 0x00800000
KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
KERNEL_INITRAMFS_SUFFIX := .itb
DEVICE_PACKAGES += f2fs-tools fdisk kmod-i2c-pxa