aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-03-28 18:25:34 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-03-28 20:52:49 +0100
commit44b457168ef7a37533929c4332c86ef084d606a6 (patch)
tree0140945bb77d8fa6a98786681fa2fa78385a28bf /target/linux/mvebu
parent068ea2cde04e2666fb05731cea941bccfaeddc25 (diff)
downloadupstream-44b457168ef7a37533929c4332c86ef084d606a6.tar.gz
upstream-44b457168ef7a37533929c4332c86ef084d606a6.tar.bz2
upstream-44b457168ef7a37533929c4332c86ef084d606a6.zip
mvebu: make boot filesystem reproducible
Set timestamp option for make_ext4fs to make boot filesystem reproducible. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 44e66a5f87..b0498d34c9 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -34,7 +34,9 @@ define Build/boot-img-ext4
$(foreach dts,$(DEVICE_DTS), $(CP) $(KDIR)/image-$(dts).dtb $@.boot/$(dts).dtb;)
$(CP) $(IMAGE_KERNEL) $@.boot/$(KERNEL_NAME)
-$(CP) $@-boot.scr $@.boot/boot.scr
- make_ext4fs -J -L kernel -l $(CONFIG_TARGET_KERNEL_PARTSIZE)M $@.bootimg $@.boot
+ make_ext4fs -J -L kernel -l $(CONFIG_TARGET_KERNEL_PARTSIZE)M \
+ $(if $(SOURCE_DATE_EPOCH),-T $(SOURCE_DATE_EPOCH)) \
+ $@.bootimg $@.boot
endef
define Build/buffalo-kernel-jffs2