aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-12-27 20:44:11 -0800
committerPaul Spooren <mail@aparcar.org>2023-02-04 02:35:03 +0100
commit2630e5063df0240eb0d05cd6e953b2bd412e3215 (patch)
treec420021efd2ad444bf7e4f9e83675fdd43ae483e /target/linux/mvebu
parent19988b66d07f44be757c4a0e41be899dbf8c72dd (diff)
downloadupstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.tar.gz
upstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.tar.bz2
upstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.zip
treewide: replace wpad-basic-wolfssl default
The newly merged mbedtls backend is smaller and has fewer ABI related issues than the wolfSSL one. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 4b8884383a..aed1d47646 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -58,7 +58,7 @@ define Device/cznic_turris-omnia
KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
DEVICE_PACKAGES := \
mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
- wpad-basic-wolfssl kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
+ wpad-basic-mbedtls kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
partx-utils kmod-i2c-mux-pca954x kmod-leds-turris-omnia
IMAGES := $$(DEVICE_IMG_PREFIX)-sysupgrade.img.gz omnia-medkit-$$(DEVICE_IMG_PREFIX)-initramfs.tar.gz
IMAGE/$$(DEVICE_IMG_PREFIX)-sysupgrade.img.gz := boot-scr | boot-img | sdcard-img | gzip | append-metadata
@@ -109,7 +109,7 @@ TARGET_DEVICES += kobol_helios4
define Device/linksys
$(Device/NAND-128K)
DEVICE_VENDOR := Linksys
- DEVICE_PACKAGES := kmod-mwlwifi wpad-basic-wolfssl
+ DEVICE_PACKAGES := kmod-mwlwifi wpad-basic-mbedtls
IMAGES += factory.img
IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
append-ubi | pad-to $$$$(PAGESIZE)