aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2022-01-01 22:00:56 +0900
committerSungbo Eo <mans0n@gorani.run>2022-01-29 23:50:28 +0900
commitf4fd2a1354a81e5222b6a263076538fbb7d4a090 (patch)
tree3c530b795daabeb96f28fb8fd1633fff3fec103f /target/linux/mvebu
parent7a4a33060ff1457df6fdfeb3257b44a01f673776 (diff)
downloadupstream-f4fd2a1354a81e5222b6a263076538fbb7d4a090.tar.gz
upstream-f4fd2a1354a81e5222b6a263076538fbb7d4a090.tar.bz2
upstream-f4fd2a1354a81e5222b6a263076538fbb7d4a090.zip
mvebu: remove duplicate CONFIG_POWER_RESET entries
The option is already enabled in the target config since 9149ed4f05f8 ("mvebu: cortexa9: Add support for Ctera C200-V2"). Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/cortexa53/config-5.101
-rw-r--r--target/linux/mvebu/cortexa72/config-5.101
-rw-r--r--target/linux/mvebu/modules.mk5
3 files changed, 1 insertions, 6 deletions
diff --git a/target/linux/mvebu/cortexa53/config-5.10 b/target/linux/mvebu/cortexa53/config-5.10
index 79f815b6d2..a47d66c669 100644
--- a/target/linux/mvebu/cortexa53/config-5.10
+++ b/target/linux/mvebu/cortexa53/config-5.10
@@ -62,7 +62,6 @@ CONFIG_PHY_MVEBU_A3700_UTMI=y
CONFIG_PINCTRL_ARMADA_37XX=y
CONFIG_PINCTRL_ARMADA_AP806=y
CONFIG_PINCTRL_ARMADA_CP110=y
-CONFIG_POWER_RESET=y
CONFIG_POWER_SUPPLY=y
CONFIG_QUEUED_RWLOCKS=y
CONFIG_QUEUED_SPINLOCKS=y
diff --git a/target/linux/mvebu/cortexa72/config-5.10 b/target/linux/mvebu/cortexa72/config-5.10
index be78be5a34..740f0fcfdf 100644
--- a/target/linux/mvebu/cortexa72/config-5.10
+++ b/target/linux/mvebu/cortexa72/config-5.10
@@ -71,7 +71,6 @@ CONFIG_PHY_MVEBU_CP110_COMPHY=y
CONFIG_PINCTRL_ARMADA_37XX=y
CONFIG_PINCTRL_ARMADA_AP806=y
CONFIG_PINCTRL_ARMADA_CP110=y
-CONFIG_POWER_RESET=y
CONFIG_POWER_SUPPLY=y
CONFIG_QUEUED_RWLOCKS=y
CONFIG_QUEUED_SPINLOCKS=y
diff --git a/target/linux/mvebu/modules.mk b/target/linux/mvebu/modules.mk
index 8d4dc4d968..2700e2b159 100644
--- a/target/linux/mvebu/modules.mk
+++ b/target/linux/mvebu/modules.mk
@@ -2,10 +2,7 @@ define KernelPackage/linkstation-poweroff
SUBMENU:=$(OTHER_MENU)
DEPENDS:=@TARGET_mvebu
TITLE:=Buffalo LinkStation power off driver
- KCONFIG:= \
- CONFIG_POWER_RESET=y \
- CONFIG_POWER_RESET_LINKSTATION
-
+ KCONFIG:=CONFIG_POWER_RESET_LINKSTATION
FILES:=$(LINUX_DIR)/drivers/power/reset/linkstation-poweroff.ko
AUTOLOAD:=$(call AutoLoad,31,linkstation-poweroff,1)
endef