aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-08-07 14:30:53 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-08-16 12:22:17 +0100
commit98bccdafd7244238d9dfbbc1a342a4bb557e4b7c (patch)
tree729ed25e871db6e2648f546f81d4ee4b36902e2c /target/linux/mvebu
parent5c13177c55d068dec3e58f8f37c1c78502f73d3d (diff)
downloadupstream-98bccdafd7244238d9dfbbc1a342a4bb557e4b7c.tar.gz
upstream-98bccdafd7244238d9dfbbc1a342a4bb557e4b7c.tar.bz2
upstream-98bccdafd7244238d9dfbbc1a342a4bb557e4b7c.zip
base-files: rename 'sdcard' to 'legacy-sdcard'
While an image layout based on MBR and 'bootfs' partition may be easy to understand for users who are very used to the IBM PC and always have the option to access the SD card outside of the device (and hence don't really depend on other recovery methods or dual-boot), in my opinion it's a dead end for many desirable features on embedded systems, especially when managed remotely (and hence without an easy option to access the SD card using another device in case things go wrong, for example). Let me explain: * using a MSDOS/VFAT filesystem to store kernel(s) is problematic, as a single corruption of the bootfs can render the system into a state that it no longer boots at all. This makes dual-boot useless, or at least very tedious to setup with then 2 independent boot partitions to avoid the single point of failure on a "hot" block (the FAT index of the boot partition, written every time a file is changed in bootfs). And well: most targets even store the bootloader environment in a file in that very same FAT filesystem, hence it cannot be used to script a reliable dual-boot method (as loading the environment itself will already fail if the filesystem is corrupted). * loading the kernel uImage from bootfs and using rootfs inside an additional partition means the bootloader can only validate the kernel -- if rootfs is broken or corrupted, this can lead to a reboot loop, which is often a quite costly thing to happen in terms of hardware lifetime. * imitating MBR-boot behavior with a FAT-formatted bootfs partition (like IBM PC in the 80s and 90s) is just one of many choices on embedded targets. There are much better options with modern U-Boot (which is what we use and build from source for all targets booting off SD cards), see examples in mediatek/mt7622 and mediatek/mt7623. Hence rename the 'sdcard' feature to 'legacy-sdcard', and prefix functions with 'legacy_sdcard_' instead of 'sdcard_'. Tested-by: Stijn Tintel <stijn@linux-ipv6.be> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/Makefile2
-rwxr-xr-xtarget/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh6
-rwxr-xr-xtarget/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh6
-rwxr-xr-xtarget/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh6
4 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
index 6b992f8903..3737a4aa23 100644
--- a/target/linux/mvebu/Makefile
+++ b/target/linux/mvebu/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
BOARD:=mvebu
BOARDNAME:=Marvell EBU Armada
-FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part sdcard
+FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part legacy-sdcard
SUBTARGETS:=cortexa9 cortexa53 cortexa72
KERNEL_PATCHVER:=5.4
diff --git a/target/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh
index 26bb022415..0ee1d61506 100755
--- a/target/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/cortexa53/base-files/lib/upgrade/platform.sh
@@ -15,7 +15,7 @@ platform_check_image() {
globalscale,espressobin-ultra|\
globalscale,espressobin-v7|\
globalscale,espressobin-v7-emmc)
- sdcard_check_image "$1"
+ legacy_sdcard_check_image "$1"
;;
*)
return 0
@@ -31,7 +31,7 @@ platform_do_upgrade() {
globalscale,espressobin-ultra|\
globalscale,espressobin-v7|\
globalscale,espressobin-v7-emmc)
- sdcard_do_upgrade "$1"
+ legacy_sdcard_do_upgrade "$1"
;;
methode,udpu)
platform_do_upgrade_uDPU "$1"
@@ -49,7 +49,7 @@ platform_copy_config() {
globalscale,espressobin-ultra|\
globalscale,espressobin-v7|\
globalscale,espressobin-v7-emmc)
- sdcard_copy_config
+ legacy_sdcard_copy_config
;;
methode,udpu)
platform_copy_config_uDPU
diff --git a/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
index 1713f55b72..74aad434ea 100755
--- a/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/cortexa72/base-files/lib/upgrade/platform.sh
@@ -11,7 +11,7 @@ platform_check_image() {
case "$(board_name)" in
marvell,armada8040-mcbin-doubleshot|\
marvell,armada8040-mcbin-singleshot)
- sdcard_check_image "$1"
+ legacy_sdcard_check_image "$1"
;;
*)
return 0
@@ -23,7 +23,7 @@ platform_do_upgrade() {
case "$(board_name)" in
marvell,armada8040-mcbin-doubleshot|\
marvell,armada8040-mcbin-singleshot)
- sdcard_do_upgrade "$1"
+ legacy_sdcard_do_upgrade "$1"
;;
*)
default_do_upgrade "$1"
@@ -34,7 +34,7 @@ platform_copy_config() {
case "$(board_name)" in
marvell,armada8040-mcbin-doubleshot|\
marvell,armada8040-mcbin-singleshot)
- sdcard_copy_config
+ legacy_sdcard_copy_config
;;
esac
}
diff --git a/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh
index bf3961c437..5e69374837 100755
--- a/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/cortexa9/base-files/lib/upgrade/platform.sh
@@ -13,7 +13,7 @@ platform_check_image() {
kobol,helios4|\
solidrun,clearfog-base-a1|\
solidrun,clearfog-pro-a1)
- sdcard_check_image "$1"
+ legacy_sdcard_check_image "$1"
;;
*)
return 0
@@ -30,7 +30,7 @@ platform_do_upgrade() {
kobol,helios4|\
solidrun,clearfog-base-a1|\
solidrun,clearfog-pro-a1)
- sdcard_do_upgrade "$1"
+ legacy_sdcard_do_upgrade "$1"
;;
linksys,wrt1200ac|\
linksys,wrt1900ac-v1|\
@@ -51,7 +51,7 @@ platform_copy_config() {
kobol,helios4|\
solidrun,clearfog-base-a1|\
solidrun,clearfog-pro-a1)
- sdcard_copy_config
+ legacy_sdcard_copy_config
;;
linksys,wrt1200ac|\
linksys,wrt1900ac-v1|\