aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2020-02-10 16:33:23 +0100
committerPetr Štetiar <ynezz@true.cz>2020-03-01 21:36:00 +0100
commit97491078f40d22b0de41675a35c8bcc667c885c3 (patch)
treeb1f63a1321251d1ab7ea245ba5612082b9434a1d /target/linux/mvebu
parent4a308bad82f3fafebc04fa4bc7cd5c3b34825575 (diff)
downloadupstream-97491078f40d22b0de41675a35c8bcc667c885c3.tar.gz
upstream-97491078f40d22b0de41675a35c8bcc667c885c3.tar.bz2
upstream-97491078f40d22b0de41675a35c8bcc667c885c3.zip
mvebu: image: keep global DTS_DIR intact
Don't rewrite global DTS_DIR, instead, use proper variable for specifying devices dts directory. For consistency, also specify the variable in default profile, as suggested by Adrian Schmutzler. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index aeabffdca2..d73f3e20fc 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -78,6 +78,7 @@ endef
define Device/Default
PROFILES := Default
DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
+ DEVICE_DTS_DIR := $(DTS_DIR)
BOARD_NAME = $$(DEVICE_DTS)
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb | uImage none
@@ -93,7 +94,7 @@ DEVICE_VARS += BOOT_SCRIPT UBOOT
define Device/Default-arm64
BOOT_SCRIPT := generic-arm64
- DTS_DIR := $(DTS_DIR)/marvell
+ DEVICE_DTS_DIR := $(DTS_DIR)/marvell
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
KERNEL_NAME := Image