aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2018-02-14 17:34:38 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-02 21:33:08 +0100
commit0ef28ea3875809ec4bebee29d908f31dd7c42b86 (patch)
tree42bbe6d060cb228d3715da83ddd0ae9606e24f0b /target/linux/mvebu
parente4fa22397f0844481ed260ed599ff3851d30b71f (diff)
downloadupstream-0ef28ea3875809ec4bebee29d908f31dd7c42b86.tar.gz
upstream-0ef28ea3875809ec4bebee29d908f31dd7c42b86.tar.bz2
upstream-0ef28ea3875809ec4bebee29d908f31dd7c42b86.zip
mvebu: unify boot.scr creation
Unify boot.scr generation so Makefile for device image generation won't grow without a reason. Also make boot-scr step optional. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/Makefile17
-rw-r--r--target/linux/mvebu/image/armada-388-clearfog-base.bootscript (renamed from target/linux/mvebu/image/cfbase-boot.script)2
-rw-r--r--target/linux/mvebu/image/armada-388-clearfog-pro.bootscript (renamed from target/linux/mvebu/image/cfpro-boot.script)2
3 files changed, 8 insertions, 13 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 1f490905ff..68adfc3ddd 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -25,14 +25,9 @@ endef
# Partition 1: 32768 sectors
# Partition 2: 98304 sectors (configurable)
-define Build/boot-scr-cfpro
- rm -f $@.bootscript
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfpro-boot.script $@.bootscript
-endef
-
-define Build/boot-scr-cfbase
- rm -f $@.bootscript
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfbase-boot.script $@.bootscript
+define Build/boot-scr
+ rm -f $@-boot.scr
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d $(DEVICE_NAME).bootscript $@-boot.scr
endef
define Build/boot-img
@@ -40,7 +35,7 @@ define Build/boot-img
mkfs.fat -C $@.boot 16384
$(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb;)
mcopy -i $@.boot $(IMAGE_KERNEL) ::zImage
- mcopy -i $@.boot $@.bootscript ::boot.scr
+ -mcopy -i $@.boot $@-boot.scr ::boot.scr
endef
define Build/sdcard-img
@@ -204,7 +199,7 @@ define Device/armada-388-clearfog-pro
DEVICE_TITLE := SolidRun ClearFog Pro
DEVICE_PACKAGES := mkf2fs e2fsprogs swconfig kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-scr-cfpro | boot-img | sdcard-img | gzip | append-metadata
+ IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip | append-metadata
DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
SUPPORTED_DEVICES := armada-388-clearfog-pro armada-388-clearfog
UBOOT := clearfog-u-boot-spl.kwb
@@ -217,7 +212,7 @@ define Device/armada-388-clearfog-base
DEVICE_TITLE := SolidRun ClearFog Base
DEVICE_PACKAGES := mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-scr-cfbase | boot-img | sdcard-img | gzip | append-metadata
+ IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip | append-metadata
DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
UBOOT := clearfog-u-boot-spl.kwb
endef
diff --git a/target/linux/mvebu/image/cfbase-boot.script b/target/linux/mvebu/image/armada-388-clearfog-base.bootscript
index 6ab6e363bc..1755203dc5 100644
--- a/target/linux/mvebu/image/cfbase-boot.script
+++ b/target/linux/mvebu/image/armada-388-clearfog-base.bootscript
@@ -1,6 +1,6 @@
# Standard Boot-Script
# use only well-known variable names provided by U-Boot Distro boot
-# This script assumes that there is a boot partition,
+# This script assumes that there is a boot partition,
# and that the root partition is always the next one.
# Override DeviceTree for Clearfog Base
diff --git a/target/linux/mvebu/image/cfpro-boot.script b/target/linux/mvebu/image/armada-388-clearfog-pro.bootscript
index 5971b0da77..4cc206dbf3 100644
--- a/target/linux/mvebu/image/cfpro-boot.script
+++ b/target/linux/mvebu/image/armada-388-clearfog-pro.bootscript
@@ -1,6 +1,6 @@
# Standard Boot-Script
# use only well-known variable names provided by U-Boot Distro boot
-# This script assumes that there is a boot partition,
+# This script assumes that there is a boot partition,
# and that the root partition is always the next one.
# rootfs is always on the next partition