aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-11-21 11:59:37 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-24 12:53:17 +0100
commit9fc0bcdd18688724494e3364ec986318372129a4 (patch)
treebcbcaab9641b9a48e2a2ed876981d25fe99739e3 /target/linux/mvebu
parentd596c21ebd5a3e6ce933eff3e51989031e4b1d58 (diff)
downloadupstream-9fc0bcdd18688724494e3364ec986318372129a4.tar.gz
upstream-9fc0bcdd18688724494e3364ec986318372129a4.tar.bz2
upstream-9fc0bcdd18688724494e3364ec986318372129a4.zip
mvebu: use image metadata for firmware validation
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/mvebu')
-rwxr-xr-xtarget/linux/mvebu/base-files/lib/upgrade/platform.sh23
-rw-r--r--target/linux/mvebu/image/Makefile5
2 files changed, 6 insertions, 22 deletions
diff --git a/target/linux/mvebu/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/base-files/lib/upgrade/platform.sh
index a8ad602cc7..77578e28d4 100755
--- a/target/linux/mvebu/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/base-files/lib/upgrade/platform.sh
@@ -6,29 +6,10 @@
. /lib/mvebu.sh
RAMFS_COPY_DATA=/lib/mvebu.sh
+REQUIRE_IMAGE_METADATA=1
platform_check_image() {
- local board=$(mvebu_board_name)
- local magic_long="$(get_magic_long "$1")"
-
- [ "$#" -gt 1 ] && return 1
-
- case "$board" in
- armada-385-linksys-caiman|armada-385-linksys-cobra|armada-385-linksys-rango|armada-385-linksys-shelby|armada-xp-linksys-mamba)
- [ "$magic_long" != "27051956" -a "$magic_long" != "73797375" ] && {
- echo "Invalid image type."
- return 1
- }
- return 0;
- ;;
- armada-388-clearfog)
- platform_check_image_clearfog "$ARGV"
- return $?
- ;;
- esac
-
- echo "Sysupgrade is not yet supported on $board."
- return 1
+ return 0
}
platform_do_upgrade() {
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 73c533ab37..8b203a4122 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -61,11 +61,12 @@ define Device/Default
BOARD_NAME = $$(DEVICE_DTS)
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb | uImage none
+ SUPPORTED_DEVICES = $$(DEVICE_DTS)
endef
define Device/UBI
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := sysupgrade-tar
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
define Device/UBI-factory
@@ -146,6 +147,7 @@ TARGET_DEVICES += linksys-wrt1900ac
define Device/openblocks-ax3
$(Device/UBI-factory)
DEVICE_DTS := armada-xp-openblocks-ax3-4
+ SUPPORTED_DEVCES := $(1)
BLOCKSIZE := 128k
PAGESIZE := 1
IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
@@ -194,6 +196,7 @@ TARGET_DEVICES += armada-388-clearfog
define Device/globalscale-mirabox
$(Device/NAND-512K)
DEVICE_DTS := armada-370-mirabox
+ SUPPORTED_DEVCES := mirabox
DEVICE_TITLE := Globalscale Mirabox
endef
TARGET_DEVICES += globalscale-mirabox