aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-10-08 10:02:10 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-10-08 10:02:10 +0000
commite1c362b60c45ec71295dbb64da3d743a50f4253c (patch)
tree67b8291767d130d7b8eb2fbe1baf23691917618b /target/linux/mvebu/profiles
parent90fb91db82e9d1b6368c4d4d74d644a579e13af9 (diff)
downloadupstream-e1c362b60c45ec71295dbb64da3d743a50f4253c.tar.gz
upstream-e1c362b60c45ec71295dbb64da3d743a50f4253c.tar.bz2
upstream-e1c362b60c45ec71295dbb64da3d743a50f4253c.zip
mvebu: add support for the Linksys WRT1900ACS (Shelby)
Backport of r47164. Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47165 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/profiles')
-rw-r--r--target/linux/mvebu/profiles/linksys.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mvebu/profiles/linksys.mk b/target/linux/mvebu/profiles/linksys.mk
index ed20cb0cf2..1a5b8afdaa 100644
--- a/target/linux/mvebu/profiles/linksys.mk
+++ b/target/linux/mvebu/profiles/linksys.mk
@@ -63,3 +63,23 @@ define Profile/Mamba/Description
endef
$(eval $(call Profile,Mamba))
+
+
+define Profile/Shelby
+ NAME:=Linksys WRT1900ACS (Shelby)
+ PACKAGES:= \
+ kmod-usb2 kmod-usb3 kmod-usb-storage \
+ kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-mvebu-ahci \
+ kmod-rtc-armada38x kmod-thermal-armada \
+ kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
+ kmod-leds-pca963x \
+ kmod-ledtrig-usbdev kmod-mwlwifi wpad-mini \
+ swconfig
+endef
+
+define Profile/Shelby/Description
+ Package set compatible with the Linksys WRT1900ACS (Shelby).
+endef
+
+$(eval $(call Profile,Shelby))