aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-02-17 17:51:46 +0000
committerLuka Perkov <luka@openwrt.org>2016-02-17 17:51:46 +0000
commit35a54abc5319178e0abd28260ec30abaa5299f19 (patch)
treea865f6e68910f5d2ff14e39cde827808c3375749 /target/linux/mvebu/profiles
parentf82063785d0a31333c452ac5d3faa7637694346e (diff)
downloadupstream-35a54abc5319178e0abd28260ec30abaa5299f19.tar.gz
upstream-35a54abc5319178e0abd28260ec30abaa5299f19.tar.bz2
upstream-35a54abc5319178e0abd28260ec30abaa5299f19.zip
mvebu: add SolidRun ClearFog A1 support
Signed-off-by: Andrej Vlasic <andrej.vlasic@sartura.hr> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48737 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/profiles')
-rw-r--r--target/linux/mvebu/profiles/solidrun.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/mvebu/profiles/solidrun.mk b/target/linux/mvebu/profiles/solidrun.mk
new file mode 100644
index 0000000000..5aa61e28a2
--- /dev/null
+++ b/target/linux/mvebu/profiles/solidrun.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Solidrun-Clearfog-A1
+ NAME:=SolidRun ClearFog A1 board
+ PACKAGES:= \
+ kmod-usb3 kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-thermal-armada kmod-rtc-marvell
+endef
+
+define Profile/Solidrun-Clearfog-A1/Description
+ Package set compatible with the SolidRun ClearFog A1 board
+endef
+
+$(eval $(call Profile,Solidrun-Clearfog-A1))