aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/modules.mk
diff options
context:
space:
mode:
authorStefan Kalscheuer <stefan@stklcode.de>2022-05-19 21:10:34 +0200
committerPetr Štetiar <ynezz@true.cz>2022-08-16 15:20:28 +0200
commit89b7714cf65e432997ca3c738afbffbd73469956 (patch)
treeec2331e486b034fbe869462471e8cfb83424fbe9 /target/linux/mvebu/modules.mk
parent5e39f37caaf41ae88f0c2d6b4e6f933cf4918287 (diff)
downloadupstream-89b7714cf65e432997ca3c738afbffbd73469956.tar.gz
upstream-89b7714cf65e432997ca3c738afbffbd73469956.tar.bz2
upstream-89b7714cf65e432997ca3c738afbffbd73469956.zip
kernel: add kmod-leds-turris-omnia
Add support for LEDs of the CZ.NIC Turris Omnia using the upstream driver. There is no generic way to control the LEDs in UCI manner, however the kernel module is the first step to actually use the RGB LEDs in custom logic. Signed-off-by: Stefan Kalscheuer <stefan@stklcode.de> (removed DMARC notice, added driver to Turris Omnia, moved module recipe to target/linux/mvebu/modules.mk) Signed-off-by: Christian Lamparter <chunkeey@gmail.com> (cherry picked from commit f8fa38c13fcc3b4ce9a4dfc56d98e5188353afac) Reviewed-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/mvebu/modules.mk')
-rw-r--r--target/linux/mvebu/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/mvebu/modules.mk b/target/linux/mvebu/modules.mk
index 2700e2b159..311cc07c7f 100644
--- a/target/linux/mvebu/modules.mk
+++ b/target/linux/mvebu/modules.mk
@@ -15,3 +15,19 @@ define KernelPackage/linkstation-poweroff/description
endef
$(eval $(call KernelPackage,linkstation-poweroff))
+
+
+define KernelPackage/leds-turris-omnia
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=LED support for CZ.NIC's Turris Omnia
+ DEPENDS:=@TARGET_mvebu_cortexa9
+ KCONFIG:=CONFIG_LEDS_TURRIS_OMNIA
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-turris-omnia.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-turris-omnia,1)
+endef
+
+define KernelPackage/leds-turris-omnia/description
+ This option enables support for the LEDs of the CZ.NIC Turris Omnia.
+endef
+
+$(eval $(call KernelPackage,leds-turris-omnia))