aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/modules.mk
diff options
context:
space:
mode:
authorDaniel González Cabanelas <dgcbueu@gmail.com>2020-08-28 11:20:36 +0200
committerDaniel Golle <daniel@makrotopia.org>2020-08-28 10:44:29 +0100
commit59c200ca0adec1759f09b129424361cca1643f9d (patch)
treed36038daf26fef7e65a71dceae92354680e84c80 /target/linux/mvebu/modules.mk
parent09faa73c53bd097666cbbe68176dd46cfcf80ee8 (diff)
downloadupstream-59c200ca0adec1759f09b129424361cca1643f9d.tar.gz
upstream-59c200ca0adec1759f09b129424361cca1643f9d.tar.bz2
upstream-59c200ca0adec1759f09b129424361cca1643f9d.zip
mvebu: backport linkstation-poweroff upstream driver
Backport the Linkstation poweroff driver from the kernel upstream (commit a7f79f99541ef) This driver is required by the Buffalo LinkStation LS421DE for a correct power off operation. It also allows to use the WoL feature. Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
Diffstat (limited to 'target/linux/mvebu/modules.mk')
-rw-r--r--target/linux/mvebu/modules.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/mvebu/modules.mk b/target/linux/mvebu/modules.mk
new file mode 100644
index 0000000000..3a5e316788
--- /dev/null
+++ b/target/linux/mvebu/modules.mk
@@ -0,0 +1,21 @@
+define KernelPackage/linkstation-poweroff
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=@TARGET_mvebu
+ TITLE:=Buffalo LinkStation power off driver
+ KCONFIG:= \
+ CONFIG_POWER_RESET=y \
+ CONFIG_POWER_RESET_LINKSTATION \
+ CONFIG_POWER_RESET_QNAP=n
+
+ FILES:=$(LINUX_DIR)/drivers/power/reset/linkstation-poweroff.ko
+ AUTOLOAD:=$(call AutoLoad,31,linkstation-poweroff,1)
+endef
+
+define KernelPackage/linkstation-poweroff/description
+ This driver supports turning off some Buffalo LinkStations by
+ setting an output pin at the ethernet PHY to the correct state.
+ It also makes the device compatible with the WoL function.
+ Say Y here if you have a Buffalo LinkStation LS421D/E.
+endef
+
+$(eval $(call KernelPackage,linkstation-poweroff))