aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-04-10 00:14:21 -1000
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-05 21:54:43 +0200
commitdf6f3090c48e3bafa0ace7450488b0a20a8074fb (patch)
treeb0f3285075a3b7544a588253d7c984e083bf6af8 /target/linux/mvebu/image
parent8c31afb978016ef71fa3bf0d4db583cf6970042b (diff)
downloadupstream-df6f3090c48e3bafa0ace7450488b0a20a8074fb.tar.gz
upstream-df6f3090c48e3bafa0ace7450488b0a20a8074fb.tar.bz2
upstream-df6f3090c48e3bafa0ace7450488b0a20a8074fb.zip
mvebu: rename Linksys devices based on their common names
The Linksys devices in mvebu target feature a mixed naming, where parts are based on the official product name (device node, image; e.g. WRT3200ACM) and parts are based on the internal code name (DTS file name, compatible, LED labels; e.g. rango). This inconsistent naming has been perceived as quite confusing. A recent attempt by Paul Spooren to harmonize this naming in kernel has been declined there. However, for us it still makes sense to apply at least a part of these changes locally. Primarily, this patch changes the compatible in DTS and thus the board name used in various scripts to have them in line with the device, model and image names. Due to the recent switch from swconfig to DSA, this allows us to drop SUPPORTED_DEVICES and thus prevent seamless upgrade between these incompatible setups. However, this does not include the LED label rename from Paul's initial patch: I don't think it's worth keeping the enormous diff locally for this case, as we can implement this much easier in 01_leds if we have to live with the inconsistency anyway. Signed-off-by: Paul Spooren <mail@aparcar.org> [rebase, extend to all devices, drop DT LED changes] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk14
1 files changed, 4 insertions, 10 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 4c7bbcd758..09f3d45e9e 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -65,7 +65,6 @@ define Device/linksys_wrt1200ac
DEVICE_ALT0_MODEL := Caiman
DEVICE_DTS := armada-385-linksys-caiman
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
- SUPPORTED_DEVICES := armada-385-linksys-caiman linksys,caiman
endef
TARGET_DEVICES += linksys_wrt1200ac
@@ -80,11 +79,10 @@ define Device/linksys_wrt1900acs
DEVICE_ALT1_MODEL := Shelby
DEVICE_DTS := armada-385-linksys-shelby
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
- SUPPORTED_DEVICES := armada-385-linksys-shelby linksys,shelby
endef
TARGET_DEVICES += linksys_wrt1900acs
-define Device/linksys_wrt1900ac
+define Device/linksys_wrt1900ac-v1
$(call Device/linksys)
DEVICE_MODEL := WRT1900AC
DEVICE_VARIANT := v1
@@ -93,11 +91,10 @@ define Device/linksys_wrt1900ac
DEVICE_DTS := armada-xp-linksys-mamba
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
KERNEL_SIZE := 3072k
- SUPPORTED_DEVICES := armada-xp-linksys-mamba linksys,mamba
endef
-TARGET_DEVICES += linksys_wrt1900ac
+TARGET_DEVICES += linksys_wrt1900ac-v1
-define Device/linksys_wrt1900acv2
+define Device/linksys_wrt1900ac-v2
$(call Device/linksys)
DEVICE_MODEL := WRT1900AC
DEVICE_VARIANT := v2
@@ -105,9 +102,8 @@ define Device/linksys_wrt1900acv2
DEVICE_ALT0_MODEL := Cobra
DEVICE_DTS := armada-385-linksys-cobra
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
- SUPPORTED_DEVICES := armada-385-linksys-cobra linksys,cobra
endef
-TARGET_DEVICES += linksys_wrt1900acv2
+TARGET_DEVICES += linksys_wrt1900ac-v2
define Device/linksys_wrt3200acm
$(call Device/linksys)
@@ -116,7 +112,6 @@ define Device/linksys_wrt3200acm
DEVICE_ALT0_MODEL := Rango
DEVICE_DTS := armada-385-linksys-rango
DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
- SUPPORTED_DEVICES := armada-385-linksys-rango linksys,rango
endef
TARGET_DEVICES += linksys_wrt3200acm
@@ -129,7 +124,6 @@ define Device/linksys_wrt32x
DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
KERNEL_SIZE := 3072k
KERNEL := kernel-bin | append-dtb
- SUPPORTED_DEVICES := armada-385-linksys-venom linksys,venom
endef
TARGET_DEVICES += linksys_wrt32x