aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorTad Davanzo <tad@spotco.us>2021-02-05 22:42:47 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-19 15:30:01 +0100
commit15309f5133d55e92bec3ed91dfb3ac9d124f6a96 (patch)
tree2e02648d2a9be92bdf70bd6f26c53aa4de0bb7a2 /target/linux/mvebu/image
parent10415d5e7016b69dc71c5f1b03e8e17b586f8edd (diff)
downloadupstream-15309f5133d55e92bec3ed91dfb3ac9d124f6a96.tar.gz
upstream-15309f5133d55e92bec3ed91dfb3ac9d124f6a96.tar.bz2
upstream-15309f5133d55e92bec3ed91dfb3ac9d124f6a96.zip
mvebu: venom resize kernel to 6MB
venom has a 3MB kernel partition as specified by the DTS. 3MB is not sufficient for building with many kernel modules or newer kernel versions. venom uboot however as set from factory will load up to 6MB. This can be observed by looking a uboot log: NAND read: device 0 offset 0x900000, size 0x600000 6291456 bytes read: OK and from uboot environment variables: $ fw_printenv | grep "priKernSize"; priKernSize=0x0600000 Resize the root partitions from 120MB to 117MB to let kernel expand into it another 3MB. And set kernel target size to 6MB. Lastly set the kernel-size-migration compatibility version on venom to prevent sysupgrading without first reinstalling from a factory image. Signed-off-by: Tad Davanzo <tad@spotco.us>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 90c0dfa827..203a04d6bc 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -154,13 +154,13 @@ TARGET_DEVICES += linksys_wrt3200acm
define Device/linksys_wrt32x
$(call Device/linksys)
- $(Device/dsa-migration)
+ $(Device/kernel-size-migration)
DEVICE_MODEL := WRT32X
DEVICE_ALT0_VENDOR := Linksys
DEVICE_ALT0_MODEL := Venom
DEVICE_DTS := armada-385-linksys-venom
DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
- KERNEL_SIZE := 3072k
+ KERNEL_SIZE := 6144k
KERNEL := kernel-bin | append-dtb
SUPPORTED_DEVICES += armada-385-linksys-venom linksys,venom
DEFAULT := n