aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-27 00:17:07 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-27 00:25:12 +0200
commit3fdb08681b36537f430dc55743c90154790554ce (patch)
tree97cf82f34d47731e9427ca6ddec0fc712a8b32f4 /target/linux/mvebu/image
parentad697aabc30875bd078275f59e69667279aa075d (diff)
downloadupstream-3fdb08681b36537f430dc55743c90154790554ce.tar.gz
upstream-3fdb08681b36537f430dc55743c90154790554ce.tar.bz2
upstream-3fdb08681b36537f430dc55743c90154790554ce.zip
mvebu: tidy up support for GL.iNet GL-MV1000
This fixes a bunch of cosmetic issues with GL.iNet GL-MV1000: - apply alphabetic sorting in multiple files - use armada-3720 prefix for DTS like for other devices - fix vendor capitalization for model in DTSes - remove trivial comment in DTS files - use DEVICE_VENDOR/DEVICE_MODEL - remove redundant SUPPORTED_DEVICES - use SOC instead of DEVICE_DTS - remove empty line at EOF Fixes: 050c24f05c85 ("mvebu: add support for GL.iNet GL-MV1000") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/cortexa53.mk17
1 files changed, 8 insertions, 9 deletions
diff --git a/target/linux/mvebu/image/cortexa53.mk b/target/linux/mvebu/image/cortexa53.mk
index 1436c1bd23..ff8f2c0930 100644
--- a/target/linux/mvebu/image/cortexa53.mk
+++ b/target/linux/mvebu/image/cortexa53.mk
@@ -1,3 +1,11 @@
+define Device/glinet_gl-mv1000
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := GL.iNet
+ DEVICE_MODEL := GL-MV1000
+ SOC := armada-3720
+endef
+TARGET_DEVICES += glinet_gl-mv1000
+
define Device/globalscale_espressobin
$(call Device/Default-arm64)
DEVICE_VENDOR := Marvell
@@ -69,12 +77,3 @@ define Device/methode_udpu
BOOT_SCRIPT := udpu
endef
TARGET_DEVICES += methode_udpu
-
-define Device/glinet_gl-mv1000
- $(call Device/Default-arm64)
- DEVICE_TITLE := GL.iNet GL-MV1000
- DEVICE_DTS := armada-gl-mv1000
- SUPPORTED_DEVICES := glinet,gl-mv1000
-endef
-TARGET_DEVICES += glinet_gl-mv1000
-