aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2018-03-07 22:10:02 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-10 01:15:22 +0100
commit584d7c53bd2d286a71fe5e8244624f59c529cb26 (patch)
treef03f34a0d88192cd2487791d6bc28e70f0ee50fe /target/linux/mvebu/image
parentbe3da900cdac3640398ed60f62bb445269aa8b50 (diff)
downloadupstream-584d7c53bd2d286a71fe5e8244624f59c529cb26.tar.gz
upstream-584d7c53bd2d286a71fe5e8244624f59c529cb26.tar.bz2
upstream-584d7c53bd2d286a71fe5e8244624f59c529cb26.zip
mvebu: new subtarget cortex A53
This commit introduces new subtarget for Marvell EBU Armada Cortex A53 processor based devices. The first device is Globalscale ESPRESSObin. Some hardware specs: SoC: Marvell Armada 3700LP (88F3720) dual core ARM Cortex A53 processor up to 1.2GHz RAM: 512MB, 1GB or 2GB DDR3 Storage: SATA interface µSD card slot with footprint for an optional 4GB EMMC 4MB SPI NOR flash for bootloader Ethernet: Topaz Networking Switch (88E6341) with 3x GbE ports Connectors: USB 3.0 USB 2.0 µUSB port connected to PL2303SA (USB to serial bridge controller) for UART access Expansion: 2x 46-pin GPIO headers for accessories and shields with I2C, GPIOs, PWM, UART, SPI, MMC, etc MiniPCIe slot Misc: Reset button, JTAG interface Currently booting only from µSD card is supported. The boards depending on date of dispatch can come with various U-Boot versions. For the newest version 2017.03-armada-17.10 no manual intervention should be needed to boot OpenWrt image. For the older ones it's necessary to modify default U-Boot environment: 1. Interrupt boot process to run U-Boot command line, 2. Run following commands: (for version 2017.03-armada-17.06 and 2017.03-armada-17.08) setenv bootcmd "load mmc 0:1 0x4d00000 boot.scr; source 0x4d00000" saveenv (for version 2015.01-armada-17.02 and 2015.01-armada-17.04) setenv bootargs "console=ttyMV0,115200 root=/dev/mmcblk0p2 rw rootwait" setenv bootcmd "ext4load mmc 0:1 ${fdt_addr} armada-3720-espressobin.dtb; ext4load mmc 0:1 ${kernel_addr} Image; booti ${kernel_addr} - ${fdt_addr}" saveenv 3. Poweroff, insert SD card with OpenWrt image, boot and enjoy. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile26
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk16
-rw-r--r--target/linux/mvebu/image/globalscale-espressobin.bootscript10
3 files changed, 50 insertions, 2 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 6e012a61e1..55e1a0b2dc 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -27,17 +27,28 @@ endef
define Build/boot-scr
rm -f $@-boot.scr
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d $(DEVICE_NAME).bootscript $@-boot.scr
+ sed -e 's#@ROOT@#$(SIGNATURE)#g' \
+ $(DEVICE_NAME).bootscript > $@-new.bootscript
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d $@-new.bootscript $@-boot.scr
endef
define Build/boot-img
rm -f $@.boot
mkfs.fat -C $@.boot 16384
$(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb;)
- mcopy -i $@.boot $(IMAGE_KERNEL) ::zImage
+ mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_NAME)
-mcopy -i $@.boot $@-boot.scr ::boot.scr
endef
+define Build/boot-img-ext4
+ rm -fR $@.boot
+ mkdir -p $@.boot
+ $(foreach dts,$(DEVICE_DTS), $(CP) $(DTS_DIR)/$(dts).dtb $@.boot;)
+ $(CP) $(IMAGE_KERNEL) $@.boot/$(KERNEL_NAME)
+ -$(CP) $@-boot.scr $@.boot/boot.scr
+ make_ext4fs -J -l 16384K $@.bootimg $@.boot
+endef
+
define Build/sdcard-img
if [ -n "$(UBOOT)" ]; then UBOOT="$(STAGING_DIR_IMAGE)/$(UBOOT)"; fi; \
ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
@@ -48,6 +59,16 @@ define Build/sdcard-img
83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
endef
+define Build/sdcard-img-ext4
+ if [ -n "$(UBOOT)" ]; then UBOOT="$(STAGING_DIR_IMAGE)/$(UBOOT)"; fi; \
+ ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
+ SIGNATURE="$(SIGNATURE)" \
+ ./gen_mvebu_sdcard_img.sh $@ \
+ $$UBOOT \
+ 83 32768 $@.bootimg \
+ 83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
+endef
+
define Build/omnia-medkit-initramfs
$(TAR) -c -T /dev/null -f $@
rm -rf $(dir $(IMAGE_KERNEL))boot
@@ -101,5 +122,6 @@ define Device/NAND-512K
endef
include cortex-a9.mk
+include cortex-a53.mk
$(eval $(call BuildImage))
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
new file mode 100644
index 0000000000..711d2c0be8
--- /dev/null
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -0,0 +1,16 @@
+ifeq ($(SUBTARGET),cortexa53)
+
+define Device/globalscale-espressobin
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+ DEVICE_TITLE := ESPRESSObin (Marvell Armada 3700 Community Board)
+ DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-usb2 kmod-usb3 kmod-usb-storage
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+ DEVICE_DTS := armada-3720-espressobin
+ DTS_DIR := $(DTS_DIR)/marvell
+ SUPPORTED_DEVICES := globalscale,espressobin
+endef
+TARGET_DEVICES += globalscale-espressobin
+
+endif
diff --git a/target/linux/mvebu/image/globalscale-espressobin.bootscript b/target/linux/mvebu/image/globalscale-espressobin.bootscript
new file mode 100644
index 0000000000..0d03ac8513
--- /dev/null
+++ b/target/linux/mvebu/image/globalscale-espressobin.bootscript
@@ -0,0 +1,10 @@
+setenv bootargs "root=PARTUUID=@ROOT@-02 rw rootwait"
+
+if test -n "${console}"; then
+ setenv bootargs "${bootargs} ${console}"
+fi
+
+load mmc 0:1 ${fdt_addr} armada-3720-espressobin.dtb
+load mmc 0:1 ${kernel_addr} Image
+
+booti ${kernel_addr} - ${fdt_addr}