aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-12 17:29:50 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-12 17:29:50 +0000
commitb0ad24f0d5bce342b432dd3a8bbaca7892c7b165 (patch)
treefe5ed8b7a900a0c68c4c83c2300a116ec179c0ca /target/linux/mvebu/image
parent2dbe131a6262a3b6d18a167e6f85d1b98c6dd285 (diff)
downloadupstream-b0ad24f0d5bce342b432dd3a8bbaca7892c7b165.tar.gz
upstream-b0ad24f0d5bce342b432dd3a8bbaca7892c7b165.tar.bz2
upstream-b0ad24f0d5bce342b432dd3a8bbaca7892c7b165.zip
mvebu: migrate mamba support to the upstreamed code
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 45400
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index da7d2174e5..443110113c 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -137,7 +137,7 @@ $(eval $(call NANDProfile,XP-DB,armada-xp-db,512KiB,4096))
$(eval $(call NANDProfile,XP-GP,armada-xp-gp,512KiB,4096))
# Boards with NAND, with subpages
-$(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512,2048))
+$(eval $(call NANDProfile,Mamba,armada-xp-linksys-mamba,128KiB,2048,512,2048))
# Boards with large NOR, where we want to use UBI
$(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
@@ -146,12 +146,12 @@ $(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB)
$(eval $(call NORProfile,385-RD,armada-385-rd,256KiB))
define Image/Build/Profile/Mamba/squashfs
- $(call Image/Build/UbinizeImage,armada-xp-mamba,,squashfs, -p 128KiB -m 2048 -s 512 -O 2048)
+ $(call Image/Build/UbinizeImage,armada-xp-linksys-mamba,,squashfs, -p 128KiB -m 2048 -s 512 -O 2048)
( \
- dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \
- dd if=$(KDIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-ubinized.bin \
+ dd if=$(KDIR)/uImage-armada-xp-linksys-mamba bs=3072k conv=sync; \
+ dd if=$(KDIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-ubinized.bin \
bs=2048 conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-factory.img
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
endef
# The Default profile should build everything