aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-03-14 22:07:08 +0100
committerMathias Kresin <dev@kresin.me>2018-03-15 07:50:41 +0100
commit2d67ef86382f32847bdfe120912cbaff11a956d5 (patch)
tree0a58acddc9d1e843545e30b6dc2ffa3fa3f7d32c /target/linux/mvebu/image
parentbf4aa52dbf9f4ecb4e48f815e30357976605a12a (diff)
downloadupstream-2d67ef86382f32847bdfe120912cbaff11a956d5.tar.gz
upstream-2d67ef86382f32847bdfe120912cbaff11a956d5.tar.bz2
upstream-2d67ef86382f32847bdfe120912cbaff11a956d5.zip
mvebu: unset uboot build by default
Initialise the UBOOT variable by default. Otherwise it will be unintended inherit to following images if set and causes an uboot build where not required. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile2
-rw-r--r--target/linux/mvebu/image/cortex-a9.mk1
2 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 55e1a0b2dc..4f6d8f529e 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -87,7 +87,9 @@ define Device/Default
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb | uImage none
SUPPORTED_DEVICES = $$(DEVICE_DTS)
+ UBOOT :=
endef
+DEVICE_VARS += UBOOT
define Device/UBI
IMAGES := sysupgrade.bin
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index aa56a721a8..d9defe880d 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -158,7 +158,6 @@ define Device/turris-omnia
IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip
IMAGE_NAME = $$(2)
DEVICE_DTS := armada-385-turris-omnia
- UBOOT :=
endef
TARGET_DEVICES += turris-omnia