aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-10-08 10:02:10 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-10-08 10:02:10 +0000
commite1c362b60c45ec71295dbb64da3d743a50f4253c (patch)
tree67b8291767d130d7b8eb2fbe1baf23691917618b /target/linux/mvebu/image
parent90fb91db82e9d1b6368c4d4d74d644a579e13af9 (diff)
downloadupstream-e1c362b60c45ec71295dbb64da3d743a50f4253c.tar.gz
upstream-e1c362b60c45ec71295dbb64da3d743a50f4253c.tar.bz2
upstream-e1c362b60c45ec71295dbb64da3d743a50f4253c.zip
mvebu: add support for the Linksys WRT1900ACS (Shelby)
Backport of r47164. Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47165 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 461e3471a9..6e1c2b22bc 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -135,6 +135,7 @@ $(eval $(call NANDProfile,XP-GP,armada-xp-gp,512KiB,4096))
$(eval $(call NANDProfile,Mamba,armada-xp-linksys-mamba,128KiB,2048,512,2048))
$(eval $(call NANDProfile,Caiman,armada-385-linksys-caiman,128KiB,2048,512,2048))
$(eval $(call NANDProfile,Cobra,armada-385-linksys-cobra,128KiB,2048,512,2048))
+$(eval $(call NANDProfile,Shelby,armada-385-linksys-shelby,128KiB,2048,512,2048))
# Boards with large NOR, where we want to use UBI
$(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
@@ -176,6 +177,16 @@ define Image/Build/Profile/Mamba/squashfs
) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
endef
+# Shelby: Linksys WRT1900ACS
+define Image/Build/Profile/Shelby/squashfs
+ $(call Image/Build/UbinizeImage,armada-385-linksys-shelby,,squashfs, -p 128KiB -m 2048 -s 512 -O 2048)
+ ( \
+ dd if=$(KDIR)/uImage-armada-385-linksys-shelby bs=6M conv=sync; \
+ dd if=$(KDIR)/$(IMG_PREFIX)-armada-385-linksys-shelby-squashfs-ubinized.bin \
+ bs=2048 conv=sync; \
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-385-linksys-shelby-squashfs-factory.img
+endef
+
###
### Marvell
###