aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-05 11:26:17 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-05 11:26:17 +0000
commitc3cc30bc84d671b3a7b2691bb841640972743c71 (patch)
treeafca398f0ed1579bc563480ffa57fea7276a5098 /target/linux/mvebu/image
parent6c1456ba13be7a2f638908c9b1a034c43c65abc2 (diff)
downloadupstream-c3cc30bc84d671b3a7b2691bb841640972743c71.tar.gz
upstream-c3cc30bc84d671b3a7b2691bb841640972743c71.tar.bz2
upstream-c3cc30bc84d671b3a7b2691bb841640972743c71.zip
mvebu: fix NAND and NOR options
All the boards but Mamba had wrong UBI options so far, making it impossible to flash the built image on their respective storage medium. Fix all of the supported boards in order to make the generated images useful. Tested on a Mirabox, an Armada XP GP and an Openblocks AX3, and used the NAND chip datasheet for the others. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44264 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index a8fc4de134..c8ec72e87c 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -125,14 +125,18 @@ define MultiProfile
endef
endef
+# Boards with NAND, without subpages
+$(eval $(call NANDProfile,370-DB,armada-370-db,512KiB,4096))
+$(eval $(call NANDProfile,370-RD,armada-370-rd,512KiB,4096))
+$(eval $(call NANDProfile,Mirabox,armada-370-mirabox,512KiB,4096))
+$(eval $(call NANDProfile,XP-DB,armada-xp-db,512KiB,4096))
+$(eval $(call NANDProfile,XP-GP,armada-xp-gp,512KiB,4096))
+
# Boards with NAND, with subpages
-$(eval $(call NANDProfile,370-DB,armada-370-db,128KiB,2048,512))
-$(eval $(call NANDProfile,370-RD,armada-370-rd,128KiB,2048,512))
$(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512))
-$(eval $(call NANDProfile,Mirabox,armada-370-mirabox,128KiB,2048,512))
-$(eval $(call NANDProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB,2048,512))
-$(eval $(call NANDProfile,XP-DB,armada-xp-db,128KiB,2048,512))
-$(eval $(call NANDProfile,XP-GP,armada-xp-gp,128KiB,2048,512))
+
+# Boards with large NOR, where we want to use UBI
+$(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
define Image/Build/Profile/Mamba/squashfs
$(call Image/Build/UbinizeImage,armada-xp-mamba,,squashfs, -p 128KiB -m 2048 -s 512)