aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-02-17 17:51:46 +0000
committerLuka Perkov <luka@openwrt.org>2016-02-17 17:51:46 +0000
commit35a54abc5319178e0abd28260ec30abaa5299f19 (patch)
treea865f6e68910f5d2ff14e39cde827808c3375749 /target/linux/mvebu/image
parentf82063785d0a31333c452ac5d3faa7637694346e (diff)
downloadupstream-35a54abc5319178e0abd28260ec30abaa5299f19.tar.gz
upstream-35a54abc5319178e0abd28260ec30abaa5299f19.tar.bz2
upstream-35a54abc5319178e0abd28260ec30abaa5299f19.zip
mvebu: add SolidRun ClearFog A1 support
Signed-off-by: Andrej Vlasic <andrej.vlasic@sartura.hr> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48737 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 6e1c2b22bc..4bf51e56b8 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -100,6 +100,26 @@ define NORProfile
endef
# $(1): Profile Name
+# $(2): DTB Name
+define MMCProfile
+ define Image/BuildKernel/Profile/$(1)
+ $(call Image/Build/DTB,$(2))
+ cp $(KDIR)/zImage-$(2) $(BIN_DIR)/zImage-$(1);
+ cp $(DTS_DIR)/$(2).dtb $(BIN_DIR)/$(1).dtb;
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call Image/Build/Profile,$(1)/Initramfs)
+ endif
+ endef
+
+ define Image/Build/Profile/$(1)/Initramfs
+ $(call Image/Build/DTB,$(2),-initramfs)
+ cp $(KDIR)/uImage-initramfs-$(2) $(BIN_DIR)/$(IMG_PREFIX)-$(2)-initramfs
+ endef
+
+ PROFILES_LIST += $(1)
+endef
+
+# $(1): Profile Name
# $(2): Sub Profiles list
define MultiProfile
define Image/BuildKernel/Profile/$(1)
@@ -143,6 +163,8 @@ $(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB)
# Boards with small NOR, where UBI doesn't make sense
$(eval $(call NORProfile,385-RD,armada-385-rd,256KiB))
+$(eval $(call MMCProfile,Solidrun-Clearfog-A1,armada-388-clearfog))
+
###
### Linksys
###