aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa9.mk
diff options
context:
space:
mode:
authorStefan Kalscheuer <stefan@stklcode.de>2022-05-19 21:10:34 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-06-24 09:18:03 +0200
commitf8fa38c13fcc3b4ce9a4dfc56d98e5188353afac (patch)
treef04c91a3cd636fb3b2f1cba308c4c40a473a8da3 /target/linux/mvebu/image/cortexa9.mk
parent79112e7d4758cc79dea506ffebdf40e00d94fa06 (diff)
downloadupstream-f8fa38c13fcc3b4ce9a4dfc56d98e5188353afac.tar.gz
upstream-f8fa38c13fcc3b4ce9a4dfc56d98e5188353afac.tar.bz2
upstream-f8fa38c13fcc3b4ce9a4dfc56d98e5188353afac.zip
kernel: add kmod-leds-turris-omnia
Add support for LEDs of the CZ.NIC Turris Omnia using the upstream driver. There is no generic way to control the LEDs in UCI manner, however the kernel module is the first step to actually use the RGB LEDs in custom logic. Signed-off-by: Stefan Kalscheuer <stefan@stklcode.de> (removed DMARC notice, added driver to Turris Omnia, moved module recipe to target/linux/mvebu/modules.mk) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/mvebu/image/cortexa9.mk')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index b06c5594bd..d9738903fb 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -59,7 +59,7 @@ define Device/cznic_turris-omnia
DEVICE_PACKAGES := \
mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
wpad-basic-wolfssl kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
- partx-utils kmod-i2c-mux-pca954x
+ partx-utils kmod-i2c-mux-pca954x kmod-leds-turris-omnia
IMAGES := $$(DEVICE_IMG_PREFIX)-sysupgrade.img.gz omnia-medkit-$$(DEVICE_IMG_PREFIX)-initramfs.tar.gz
IMAGE/$$(DEVICE_IMG_PREFIX)-sysupgrade.img.gz := boot-scr | boot-img | sdcard-img | gzip | append-metadata
IMAGE/omnia-medkit-$$(DEVICE_IMG_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip