aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa9.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2022-01-01 23:47:43 +0900
committerSungbo Eo <mans0n@gorani.run>2022-01-29 23:50:28 +0900
commit6ff970bb51f53c731b0612152734cec82ca92543 (patch)
tree3964a5a7292c19aa47afd7b5071b4b8a95bec1f2 /target/linux/mvebu/image/cortexa9.mk
parentf4fd2a1354a81e5222b6a263076538fbb7d4a090 (diff)
downloadupstream-6ff970bb51f53c731b0612152734cec82ca92543.tar.gz
upstream-6ff970bb51f53c731b0612152734cec82ca92543.tar.bz2
upstream-6ff970bb51f53c731b0612152734cec82ca92543.zip
mvebu: add support for ipTIME NAS1dual
ipTIME NAS1dual is a 1-bay NAS, based on Marvell Armada 385 SoC. Specifications: * SoC: 88F6820 * RAM: 2 GiB * Flash: SPI NOR 64 MiB * SATA: 1x 3Gb/s * Ethernet: 2x 1GbE * USB: 1x 3.0 * Fan: 2 speed level * UART: J11 (115200 8N1) * Pinout: [3V3] (TXD) (RXD) (GND) Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: 1. Perform sysupgrade with stock image. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/mvebu/image/cortexa9.mk')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 06252670ab..b06c5594bd 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -78,6 +78,20 @@ define Device/globalscale_mirabox
endef
TARGET_DEVICES += globalscale_mirabox
+define Device/iptime_nas1dual
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := NAS1dual
+ DEVICE_PACKAGES := kmod-hwmon-drivetemp kmod-hwmon-gpiofan kmod-usb3
+ SOC := armada-385
+ KERNEL := kernel-bin | append-dtb | iptime-naspkg nas1dual
+ KERNEL_SIZE := 6144k
+ IMAGES := sysupgrade.bin
+ IMAGE_SIZE := 64256k
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | \
+ append-rootfs | pad-rootfs | check-size | append-metadata
+endef
+TARGET_DEVICES += iptime_nas1dual
+
define Device/kobol_helios4
DEVICE_VENDOR := Kobol
DEVICE_MODEL := Helios4