aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa9.mk
diff options
context:
space:
mode:
authorDaniel González Cabanelas <dgcbueu@gmail.com>2020-08-28 11:20:46 +0200
committerDaniel Golle <daniel@makrotopia.org>2020-08-28 10:44:29 +0100
commit42d14ace3e381ec04a7c8fa233eaaff8fa3a0820 (patch)
tree5e06cf9ee88929a4cc7ac2c1c1000dfdcdc196e7 /target/linux/mvebu/image/cortexa9.mk
parent59c200ca0adec1759f09b129424361cca1643f9d (diff)
downloadupstream-42d14ace3e381ec04a7c8fa233eaaff8fa3a0820.tar.gz
upstream-42d14ace3e381ec04a7c8fa233eaaff8fa3a0820.tar.bz2
upstream-42d14ace3e381ec04a7c8fa233eaaff8fa3a0820.zip
mvebu: LS421DE: add linkstation poweroff driver
Compile the Linkstation poweroff module for the Buffalo LS421DE. Without this driver the device remains forever halted if a power off command is executed. The driver will also allow to use the WoL feature, which wasn't availabe in the stock firmware. Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
Diffstat (limited to 'target/linux/mvebu/image/cortexa9.mk')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 7c2069ed2f..824f142a8b 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -24,8 +24,8 @@ define Device/buffalo_ls421de
DEVICE_DTS := armada-370-buffalo-ls421de
DEVICE_PACKAGES := \
kmod-rtc-rs5c372a kmod-hwmon-gpiofan kmod-hwmon-drivetemp kmod-usb3 \
- kmod-md-raid0 kmod-md-raid1 kmod-md-mod kmod-fs-xfs mkf2fs e2fsprogs \
- partx-utils
+ kmod-linkstation-poweroff kmod-md-raid0 kmod-md-raid1 kmod-md-mod \
+ kmod-fs-xfs mkf2fs e2fsprogs partx-utils
endef
TARGET_DEVICES += buffalo_ls421de