aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa9.mk
diff options
context:
space:
mode:
authorTad Davanzo <tad@spotco.us>2021-02-05 22:38:03 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-29 21:17:31 +0200
commit8458ebe18b84702039020c523018e39f564ccf6c (patch)
treeb4d62e644aebc8aac9831be2519e3b53a48506dd /target/linux/mvebu/image/cortexa9.mk
parent7939d4a1b13b0c44dbfa4cd03180fe4cd5b2fe6b (diff)
downloadupstream-8458ebe18b84702039020c523018e39f564ccf6c.tar.gz
upstream-8458ebe18b84702039020c523018e39f564ccf6c.tar.bz2
upstream-8458ebe18b84702039020c523018e39f564ccf6c.zip
mvebu: mamba resize kernel to 4MB
mamba has a 3MB kernel partition as specified by the DTS. 3MB is not sufficient for building with many kernel modules or newer kernel versions. mamba uboot however as set from factory will load up to 4MB. This can be observed by looking a uboot log: NAND read: device 0 offset 0xa00000, size 0x400000 4194304 bytes read: OK and from uboot environment variables: $ fw_printenv | grep "pri_kern_size"; pri_kern_size=0x400000 Resize the root partitions from 37MB to 36MB to let kernel expand into it another 1MB. And set kernel target size to 4MB. Lastly add a compatibility version message: kernel-size-migration. And set it on mamba to prevent sysupgrading without first reinstalling from a factory image. Signed-off-by: Tad Davanzo <tad@spotco.us> (cherry picked from commit 10415d5e7016b69dc71c5f1b03e8e17b586f8edd)
Diffstat (limited to 'target/linux/mvebu/image/cortexa9.mk')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 61f4d17813..780b1a18c8 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -8,6 +8,12 @@ define Device/dsa-migration
DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
endef
+define Device/kernel-size-migration
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := Partition design has changed compared to older versions (up to 19.07) due to kernel size restrictions. \
+ Upgrade via sysupgrade mechanism is not possible, so new installation via factory style image is required.
+endef
+
define Device/buffalo_ls421de
$(Device/NAND-128K)
DEVICE_VENDOR := Buffalo
@@ -108,14 +114,14 @@ TARGET_DEVICES += linksys_wrt1900acs
define Device/linksys_wrt1900ac-v1
$(call Device/linksys)
- $(Device/dsa-migration)
+ $(Device/kernel-size-migration)
DEVICE_MODEL := WRT1900AC
DEVICE_VARIANT := v1
DEVICE_ALT0_VENDOR := Linksys
DEVICE_ALT0_MODEL := Mamba
DEVICE_DTS := armada-xp-linksys-mamba
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
- KERNEL_SIZE := 3072k
+ KERNEL_SIZE := 4096k
SUPPORTED_DEVICES += armada-xp-linksys-mamba linksys,mamba
DEFAULT := n
endef