aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa9.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-16 14:55:40 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-16 16:26:29 +0100
commit6508766d24dd391880658ab5fe70385b3b37e286 (patch)
treef225fe185d176144839cde4371c5f3d7046f4617 /target/linux/mvebu/image/cortexa9.mk
parent8adcfe289ce5328ee1ff62fcfc8b244012738c50 (diff)
downloadupstream-6508766d24dd391880658ab5fe70385b3b37e286.tar.gz
upstream-6508766d24dd391880658ab5fe70385b3b37e286.tar.bz2
upstream-6508766d24dd391880658ab5fe70385b3b37e286.zip
kernel: make kmod-i2c-mux selected by dependent modules
Currently kmod-i2c-mux-* will not get into images unless kmod-i2c-mux is added to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to "select", we do not have the issue anymore. Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES and similar variables, as it is now pulled by dependent modules such as: - kmod-i2c-mux-pca954x Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/mvebu/image/cortexa9.mk')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index a215536bf8..85bfa94dbd 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -15,7 +15,7 @@ define Device/cznic_turris-omnia
DEVICE_PACKAGES := \
mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
wpad-basic kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
- partx-utils kmod-i2c-mux kmod-i2c-mux-pca954x
+ partx-utils kmod-i2c-mux-pca954x
IMAGES := $$(IMAGE_PREFIX)-sysupgrade.img.gz omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz
IMAGE/$$(IMAGE_PREFIX)-sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip