aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa72.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2020-01-31 16:46:14 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-01 20:02:36 +0100
commit87b14bc6c289e7e80052b344c0f0c35e95ced267 (patch)
tree0e5d52a73e81649f71e6e050a4caea806c6fd89d /target/linux/mvebu/image/cortexa72.mk
parent67ac189e4ba8f49db428869de0837b85f3b827c7 (diff)
downloadupstream-87b14bc6c289e7e80052b344c0f0c35e95ced267.tar.gz
upstream-87b14bc6c289e7e80052b344c0f0c35e95ced267.tar.bz2
upstream-87b14bc6c289e7e80052b344c0f0c35e95ced267.zip
mvebu: image: align subtargets makefile names
Align subtargets makefiles names to actual subtargets. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl> Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/mvebu/image/cortexa72.mk')
-rw-r--r--target/linux/mvebu/image/cortexa72.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortexa72.mk b/target/linux/mvebu/image/cortexa72.mk
new file mode 100644
index 0000000000..a7a4d7c2e7
--- /dev/null
+++ b/target/linux/mvebu/image/cortexa72.mk
@@ -0,0 +1,29 @@
+define Device/marvell_armada7040-db
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := Marvell
+ DEVICE_MODEL := Armada 7040 Development Board
+ DEVICE_DTS := armada-7040-db
+ IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+endef
+TARGET_DEVICES += marvell_armada7040-db
+
+define Device/marvell_armada8040-db
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := Marvell
+ DEVICE_MODEL := Armada 8040 Development Board
+ DEVICE_DTS := armada-8040-db
+ IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+endef
+TARGET_DEVICES += marvell_armada8040-db
+
+define Device/marvell_macchiatobin
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := SolidRun
+ DEVICE_MODEL := MACCHIATObin
+ DEVICE_ALT0_VENDOR := SolidRun
+ DEVICE_ALT0_MODEL := Armada 8040 Community Board
+ DEVICE_PACKAGES += kmod-i2c-core kmod-i2c-mux kmod-i2c-mux-pca954x
+ DEVICE_DTS := armada-8040-mcbin
+ SUPPORTED_DEVICES := marvell,armada8040-mcbin
+endef
+TARGET_DEVICES += marvell_macchiatobin