aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a9.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-05-11 19:37:30 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-11 23:11:04 +0200
commitfb005d688ea2955df89279d75499fca26e2f6f00 (patch)
treebdc3278eca2474ae0fea7c99bbb701f1e11f6b4a /target/linux/mvebu/image/cortex-a9.mk
parentef384c68e7271a6e9a652e26fe8adf4c822f0213 (diff)
downloadupstream-fb005d688ea2955df89279d75499fca26e2f6f00.tar.gz
upstream-fb005d688ea2955df89279d75499fca26e2f6f00.tar.bz2
upstream-fb005d688ea2955df89279d75499fca26e2f6f00.zip
mvebu: image: introduce BOOT_SCRIPT variable
All of U-Boot scripts repeat the same pattern with only Device Tree blob name changing for respective device. Therefore create generic scripts which will be altered on demad by image build process, and create BOOT_SCRIPT variable which can be added to device recipe and will allow referencing the same script by many device recipes. This will allow to slim down the ammount of files in buildroot tree and avoid needlessly incrementing amount of boot scripts if new devices will be added. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/cortex-a9.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a9.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index 66cf54f9c5..8e9ef41fb6 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -132,6 +132,7 @@ define Device/armada-388-clearfog-pro
DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
SUPPORTED_DEVICES := armada-388-clearfog-pro armada-388-clearfog
UBOOT := clearfog-u-boot-spl.kwb
+ BOOT_SCRIPT := clearfog
endef
TARGET_DEVICES += armada-388-clearfog-pro
@@ -142,8 +143,9 @@ define Device/armada-388-clearfog-base
DEVICE_PACKAGES := mkf2fs e2fsprogs partx-utils
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
- DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
+ DEVICE_DTS := armada-388-clearfog-base armada-388-clearfog-pro
UBOOT := clearfog-u-boot-spl.kwb
+ BOOT_SCRIPT := clearfog
endef
TARGET_DEVICES += armada-388-clearfog-base