aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a9.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-05-11 19:37:34 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-11 23:11:04 +0200
commitee96fa15b1866d802a9a74dba2d6b1f81084e5f1 (patch)
tree1c7d2e64a149699b7923f26fcd1e6ff35c820a46 /target/linux/mvebu/image/cortex-a9.mk
parenta39d2a8053a656f75ffdd914d433e33fef86ee3e (diff)
downloadupstream-ee96fa15b1866d802a9a74dba2d6b1f81084e5f1.tar.gz
upstream-ee96fa15b1866d802a9a74dba2d6b1f81084e5f1.tar.bz2
upstream-ee96fa15b1866d802a9a74dba2d6b1f81084e5f1.zip
mvebu: use device-tree board detection
Convert whole target to Device Tree based board detection instead of identifying devices by dts file name. With this we can drop mvebu.sh translation script and rely on common method for model detection. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/cortex-a9.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a9.mk20
1 files changed, 17 insertions, 3 deletions
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index baaeb8ddb6..401da3afaf 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -20,6 +20,7 @@ define Device/linksys_wrt1200ac
$(call Device/linksys,WRT1200AC (Caiman))
DEVICE_DTS := armada-385-linksys-caiman
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
+ SUPPORTED_DEVICES := armada-385-linksys-caiman linksys,caiman
endef
TARGET_DEVICES += linksys_wrt1200ac
@@ -27,6 +28,7 @@ define Device/linksys_wrt1900acv2
$(call Device/linksys,WRT1900ACv2 (Cobra))
DEVICE_DTS := armada-385-linksys-cobra
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
+ SUPPORTED_DEVICES := armada-385-linksys-cobra linksys,cobra
endef
TARGET_DEVICES += linksys_wrt1900acv2
@@ -34,6 +36,7 @@ define Device/linksys_wrt3200acm
$(call Device/linksys,WRT3200ACM (Rango))
DEVICE_DTS := armada-385-linksys-rango
DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
+ SUPPORTED_DEVICES := armada-385-linksys-rango linksys,rango
endef
TARGET_DEVICES += linksys_wrt3200acm
@@ -41,6 +44,7 @@ define Device/linksys_wrt1900acs
$(call Device/linksys,WRT1900ACS (Shelby))
DEVICE_DTS := armada-385-linksys-shelby
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
+ SUPPORTED_DEVICES := armada-385-linksys-shelby linksys,shelby
endef
TARGET_DEVICES += linksys_wrt1900acs
@@ -50,6 +54,7 @@ define Device/linksys_wrt32x
DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
KERNEL_SIZE := 3072k
KERNEL := kernel-bin | append-dtb
+ SUPPORTED_DEVICES := armada-385-linksys-venom linksys,venom
endef
TARGET_DEVICES += linksys_wrt32x
@@ -58,12 +63,13 @@ define Device/linksys_wrt1900ac
DEVICE_DTS := armada-xp-linksys-mamba
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
KERNEL_SIZE := 3072k
+ SUPPORTED_DEVICES := armada-xp-linksys-mamba linksys,mamba
endef
TARGET_DEVICES += linksys_wrt1900ac
define Device/plathome_openblocks-ax3-4
DEVICE_DTS := armada-xp-openblocks-ax3-4
- SUPPORTED_DEVICES := openblocks-ax3-4
+ SUPPORTED_DEVICES += openblocks-ax3-4
BLOCKSIZE := 128k
PAGESIZE := 1
IMAGES += factory.img
@@ -78,6 +84,7 @@ define Device/marvell_a385-db-ap
IMAGES += factory.img
KERNEL_SIZE := 8192k
DEVICE_TITLE := Marvell Armada 385 DB AP (DB-88F6820-AP)
+ SUPPORTED_DEVICES += armada-385-db-ap
endef
TARGET_DEVICES += marvell_a385-db-ap
@@ -85,6 +92,7 @@ define Device/marvell_a370-db
$(Device/NAND-512K)
DEVICE_TITLE := Marvell Armada 370 DB (DB-88F6710-BP-DDR3)
DEVICE_DTS := armada-370-db
+ SUPPORTED_DEVICES += armada-370-db
endef
TARGET_DEVICES += marvell_a370-db
@@ -92,6 +100,7 @@ define Device/marvell_a370-rd
$(Device/NAND-512K)
DEVICE_TITLE := Marvell Armada 370 RD (RD-88F6710-A1)
DEVICE_DTS := armada-370-rd
+ SUPPORTED_DEVICES += armada-370-rd
endef
TARGET_DEVICES += marvell_a370-rd
@@ -99,6 +108,7 @@ define Device/marvell_axp-db
$(Device/NAND-512K)
DEVICE_TITLE := Marvell Armada XP DB (DB-78460-BP)
DEVICE_DTS := armada-xp-db
+ SUPPORTED_DEVICES += armada-xp-db
endef
TARGET_DEVICES += marvell_axp-db
@@ -106,6 +116,7 @@ define Device/marvell_axp-gp
$(Device/NAND-512K)
DEVICE_TITLE := Marvell Armada XP GP (DB-MV784MP-GP)
DEVICE_DTS := armada-xp-gp
+ SUPPORTED_DEVICES += armada-xp-gp
endef
TARGET_DEVICES += marvell_axp-gp
@@ -114,6 +125,7 @@ define Device/marvell_a388-rd
DEVICE_DTS := armada-388-rd
IMAGES := firmware.bin
IMAGE/firmware.bin := append-kernel | pad-to 256k | append-rootfs | pad-rootfs
+ SUPPORTED_DEVICES := armada-388-rd marvell,a385-rd
endef
TARGET_DEVICES += marvell_a388-rd
@@ -125,7 +137,7 @@ define Device/solidrun_clearfog-pro-a1
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
- SUPPORTED_DEVICES := armada-388-clearfog-pro armada-388-clearfog
+ SUPPORTED_DEVICES += armada-388-clearfog armada-388-clearfog-pro
UBOOT := clearfog-u-boot-spl.kwb
BOOT_SCRIPT := clearfog
endef
@@ -139,6 +151,7 @@ define Device/solidrun_clearfog-base-a1
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-388-clearfog-base armada-388-clearfog-pro
+ SUPPORTED_DEVICES += armada-388-clearfog-base
UBOOT := clearfog-u-boot-spl.kwb
BOOT_SCRIPT := clearfog
endef
@@ -147,7 +160,7 @@ TARGET_DEVICES += solidrun_clearfog-base-a1
define Device/globalscale_mirabox
$(Device/NAND-512K)
DEVICE_DTS := armada-370-mirabox
- SUPPORTED_DEVICES := mirabox
+ SUPPORTED_DEVICES += mirabox
DEVICE_TITLE := Globalscale Mirabox
endef
TARGET_DEVICES += globalscale_mirabox
@@ -166,6 +179,7 @@ define Device/cznic_turris-omnia
IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip
IMAGE_NAME = $$(2)
DEVICE_DTS := armada-385-turris-omnia
+ SUPPORTED_DEVICES += armada-385-turris-omnia
endef
TARGET_DEVICES += cznic_turris-omnia