aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a9.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-05-11 19:37:31 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-11 23:11:04 +0200
commit9509a6df0bff483fc165bc5da98f03d2d736622f (patch)
tree8169106db4cc27a76d32ffe58f7e99b974d4b750 /target/linux/mvebu/image/cortex-a9.mk
parentfb005d688ea2955df89279d75499fca26e2f6f00 (diff)
downloadupstream-9509a6df0bff483fc165bc5da98f03d2d736622f.tar.gz
upstream-9509a6df0bff483fc165bc5da98f03d2d736622f.tar.bz2
upstream-9509a6df0bff483fc165bc5da98f03d2d736622f.zip
mvebu: image: improve readability of device recipes
Drop overly complex amount of defines wich are referenced in the same devices pool and move image recipes to common define, since devices not using them overwrite it. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/cortex-a9.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a9.mk39
1 files changed, 14 insertions, 25 deletions
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index 8e9ef41fb6..252300b942 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -9,19 +9,15 @@
ifeq ($(SUBTARGET),cortexa9)
define Device/linksys
- DEVICE_TITLE := Linksys $(1)
- DEVICE_PACKAGES := kmod-mwlwifi wpad-basic swconfig
-endef
-
-define Device/armada-385-linksys
$(Device/NAND-128K)
- $(Device/UBI-factory)
+ DEVICE_TITLE := Linksys $(1)
+ DEVICE_PACKAGES := kmod-mwlwifi swconfig wpad-basic
+ IMAGES += factory.img
KERNEL_SIZE := 6144k
endef
define Device/linksys-wrt1200ac
$(call Device/linksys,WRT1200AC (Caiman))
- $(Device/armada-385-linksys)
DEVICE_DTS := armada-385-linksys-caiman
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
endef
@@ -29,7 +25,6 @@ TARGET_DEVICES += linksys-wrt1200ac
define Device/linksys-wrt1900acv2
$(call Device/linksys,WRT1900ACv2 (Cobra))
- $(Device/armada-385-linksys)
DEVICE_DTS := armada-385-linksys-cobra
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
endef
@@ -37,7 +32,6 @@ TARGET_DEVICES += linksys-wrt1900acv2
define Device/linksys-wrt3200acm
$(call Device/linksys,WRT3200ACM (Rango))
- $(Device/armada-385-linksys)
DEVICE_DTS := armada-385-linksys-rango
DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
endef
@@ -45,17 +39,15 @@ TARGET_DEVICES += linksys-wrt3200acm
define Device/linksys-wrt1900acs
$(call Device/linksys,WRT1900ACS (Shelby))
- $(Device/armada-385-linksys)
DEVICE_DTS := armada-385-linksys-shelby
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
endef
TARGET_DEVICES += linksys-wrt1900acs
define Device/linksys-wrt32x
-$(call Device/linksys,WRT32X (Venom))
+ $(call Device/linksys,WRT32X (Venom))
DEVICE_DTS := armada-385-linksys-venom
DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
- $(Device/armada-385-linksys)
KERNEL_SIZE := 3072k
KERNEL := kernel-bin | append-dtb
endef
@@ -65,18 +57,16 @@ define Device/linksys-wrt1900ac
$(call Device/linksys,WRT1900AC (Mamba))
DEVICE_DTS := armada-xp-linksys-mamba
DEVICE_PACKAGES += mwlwifi-firmware-88w8864
- $(Device/NAND-128K)
- $(Device/UBI-factory)
KERNEL_SIZE := 3072k
endef
TARGET_DEVICES += linksys-wrt1900ac
define Device/openblocks-ax3-4
- $(Device/UBI-factory)
DEVICE_DTS := armada-xp-openblocks-ax3-4
SUPPORTED_DEVICES := $(1)
BLOCKSIZE := 128k
PAGESIZE := 1
+ IMAGES += factory.img
IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
DEVICE_TITLE := Plat'Home OpenBlocks AX3
endef
@@ -84,34 +74,33 @@ TARGET_DEVICES += openblocks-ax3-4
define Device/armada-385-db-ap
$(Device/NAND-256K)
- $(Device/UBI-factory)
+ IMAGES += factory.img
KERNEL_SIZE := 8192k
DEVICE_TITLE := Marvell Armada 385 DB AP (DB-88F6820-AP)
endef
TARGET_DEVICES += armada-385-db-ap
-define Device/marvell-nand
- $(Device/NAND-512K)
- DEVICE_TITLE := Marvell Armada $(1)
-endef
-
define Device/armada-370-db
- $(call Device/marvell-nand,370 DB (DB-88F6710-BP-DDR3))
+ $(Device/NAND-512K)
+ DEVICE_TITLE := Marvell Armada 370 DB (DB-88F6710-BP-DDR3)
endef
TARGET_DEVICES += armada-370-db
define Device/armada-370-rd
- $(call Device/marvell-nand,370 RD (RD-88F6710-A1))
+ $(Device/NAND-512K)
+ DEVICE_TITLE := Marvell Armada 370 RD (RD-88F6710-A1)
endef
TARGET_DEVICES += armada-370-rd
define Device/armada-xp-db
- $(call Device/marvell-nand,XP DB (DB-78460-BP))
+ $(Device/NAND-512K)
+ DEVICE_TITLE := Marvell Armada XP DB (DB-78460-BP)
endef
TARGET_DEVICES += armada-xp-db
define Device/armada-xp-gp
- $(call Device/marvell-nand,XP GP (DB-MV784MP-GP))
+ $(Device/NAND-512K)
+ DEVICE_TITLE := Marvell Armada XP GP (DB-MV784MP-GP)
endef
TARGET_DEVICES += armada-xp-gp